Backup status - notifications

Asked by Brian on 2016-05-12

I am unable to see the status of backup as I understand I am supposed to see in notifications. I have done a reboot since install. I can verify that the backup process is active, even when the program window is closed, so that portion appears fine. I am using Ubuntu 16.04 LTS (Xenial Xerus) 64-bit with the latest, and freshly installed, version of sbackup. All updates via Software updater have been done as of this time and has had no impact on this issue, before or after the last update.

I looked for a setting for this and could find none. I have the Notification Area on the panel and use it for other applications, so that is there and working. Where else might I look to resolve this issue?

Question information

Language:
English Edit question
Status:
Solved
For:
sbackup Edit question
Assignee:
No assignee Edit question
Solved by:
Brian
Solved:
2016-05-24
Last query:
2016-05-24
Last reply:
Brian (thwaller) said : #1

I have resolved this issue. I am closing the question as solved. The issue ended up being that my Ubuntu flavor, MATE, was not supported, the session was not found. This was the fix:

Edit the file system.py (mine is here /usr/share/sbackup/sbackup/util/system.py) and find the following line:

_sessionnames = ("x-session-manager", "gnome-session", "gnome-shell",
"ksmserver", "xfce4-session")

Change it to:

_sessionnames = ("x-session-manager", "gnome-session", "gnome-shell",
"ksmserver", "xfce4-session", "mate-session")

Underberg (ubuuse) said : #2

Have same problem but using ubuntu 16.04 no flavor.
No status notification appears.
Haven’t found issue yet.
Someone a idea what the problem could be?

This is due to the bug #1582080 . The problem is that from ubuntu 16.04, the right to see the Desktop Session environment has been restricted. A fix is to committed http://bazaar.launchpad.net/~sbackup-dev/sbackup/0.11/revision/287

You might be able to apply it on your system manually.