Unable schedule custom profile

Asked by Marcelo Costa on 2014-05-16

Hello,

I am testing many backup solutions fo my Ubuntu server. The sbackup is more simple and organized that i found. The developers are great!

But, I have the issue with the schedule in custom profiles. The schedule tab is gray in all custom profiles. In the default profiles it's ok. The schedule tab is showed.

I run the sbackup with admin privilegies, sudo and gksudo also tested.

My Ubuntu version is 13.10.
My desktop is xubuntu (xfce)
sbackup version is 0.11.6

Regards,
Marcelo Costa
Porto Alegre, Brazil

Question information

Language:
English Edit question
Status:
Answered
For:
sbackup Edit question
Assignee:
No assignee Edit question
Last query:
2014-05-16
Last reply:
2014-05-19
Jean-Peer Lorenz (peer.loz) said : #1

Thanks for using sbackup. Unfortunately, in current versions (0.11.6) it is not possible to set different schedules for custom profiles. The reason for this is the use of cron for the actual scheduling of jobs: cron runs sbackup and sbackup itself runs all found profiles subsequently.

Please note that I'm working on this to allow completely independent settings and schedules for each profile, but this feature is not finished yet, see my sbackup/next branch :-).

Hope this helps. Please let me know if you need more information.

Best regards,
jploz

LarryE (cppljevans) said : #2

Hi Jean-Peer,

Couldn't you just create a new shell script whose name is something like sbackup.<profile-name>.sh
where <profile-name> is the name of the sbackup profile (maybe prefixed with users name).
and then schedule that with cron?

-regards,
Larry

Can you help with this problem?

Provide an answer of your own, or ask Marcelo Costa for more information if necessary.

To post a message you must log in.