Cannot schedule backups, "schedule" tab greyed out

Asked by Yada Yada on 2010-12-29

*** [Added anon] I may have semi-solved this myself but shall leave the question here as a guide if anyone else hits this issue: ***
It seems sbackup is already installed, perhaps by default, in Ubuntu 10.10 in another location. You can find it under Applications --> System Tools. When I installed it, as the guides indicated, I found an entry under Applications --> Accessories, as described below. The instance under Applications --> Accessories doesn't permit scheduled backups but once I found the other one, that has an active Schedule tab and will do scheduled backups, albeit not immediately (perhaps just after the computer is turned on?). So basically the problem seems to be out of date or inaccurate documentation with regards to
- whether you need to install it
- where it can be found once installed

Original question follows :

Using Ubuntu 10.10 (Maverick Meerkat)
Installed sbackup 0.11.3
(I note that the config and restoration items appear in Applications --> Accessories menu, contrary to every piece of online documentation, a recent book I bought called Ubuntu Kung Fu and even a magazine I saw in a shop today)
I can create a manual backup so it looks like it is set up OK. I told it to do a full backup at least every 1 day in the 'General' tab. I have yet to see the backup file appear automatically though and have been watching it for 2 days...
Most oddly, the tab which all documentation I've seen shows titled as "Time", is titled "Schedule" and is greyed out. It looks like there is an option called "Simple" there which is selected. Current profile is shown as "Default profile".

I would like to know, mainly, how to get the scheduled backups going once a day. Secondarily, I would be interested to know why that tab is greyed out.

As I am relatively new to Ubuntu I am not sure if this is a bug or some error on my part, like not installing another program which more experienced users have naturally accumulated on their systems by now. Synaptic only seemed to indicate one other package was needed, called sbackup-gtk, which I installed. I have tried reinstalling sbackup from its home site as well as the default Ubuntu code repository where Synaptic originally found it.

Thanks in anticipation 8)

Question information

English Edit question
sbackup Edit question
No assignee Edit question
Solved by:
Jean-Peer Lorenz
Last query:
Last reply:
Best Jean-Peer Lorenz (peer.loz) said : #1

Thanks for using SBackup. Related information can be found here:

Yada Yada (paulh-furfur) said : #2

Thank you, this explains what's happened and why. I was obviously thinking along different lines to the developers. I hope the how-to documents scattered round the Web are updated to reflect these new menu location(s) soon.

punkrtekk (krtek) said : #3

I simply believe it is because one link points at "gksu sbackup" which means it opens application with the privileges of root. Only root can set up cron (background automated tasks), therefore "Schedule" does not work for a common non-privileged user...