Snapshot version not supported

Asked by niewo on 2010-10-15

I have a server running daily inc-backups and weekly full-backups.
Two days ago, I updates from Ubuntu 10.04 to 10.10.
Since the machine's not working properly after the update, I decided to set it back via an sbackup-backup.

When choosing the last full backup from last saturday, I get the error "Snapshot version not supported ... please update".
After checking the last backups, I see that from the day of the distribution update, the backup's version changes from 1.4 to 1.5.

What do I have to do?
Do I have to install a fresh 10.04 fist or is there something else I can do?

Greetz
Chris

You have 2 solutions, the first one from the restoration GUI (sbackup-restore-gtk), select the date of your backup and the backup file. Then go in the Snapshot management and select the upgrade snapshot option. You'll have to do that for all your backup files.
The second option is to convert all your backup from version 1.4 to 1.5 with sbackup-upgrade-backups backup_dir_path where backup_dir_path is the path where your backups are.

Jean-Peer Lorenz (peer.loz) said : #2

Please note that it is strongly advised to make a copy of the snapshot folders before you upgrade them. The Upgrade of snapshots touches your backuped data and might damage it.

taka khumbartha (scar) said : #3

i tried using the 'update' button in the gtk gui and received this error:

Unable to upgrade snapshot

While attempting to upgrade snapshot the following error occurred:
[Errno 2] No such file or directory: 'file:///media/4A43-0B5E/throne/2010-10-16_03.33.56.248402.throne.ful/files.snar'

and, it corrupted the backup i think since it's no longer showing up in the calendar (i did make a backup of the backup though, thanks for the warning).

the backup files are located on a fat32 volume, perhaps that is the issue. i will check on that, also will try using sbackup-upgrade-backups.

taka khumbartha (scar) said : #4

i tried moving the backups to an NFS ext3 mount, still got the same error with sbackup-restore-gtk.

then, i tried using the command-line utility sbackup-upgrade-backups, again from the NFS mount. that seems to be working. it spends some time creating the SNAR file but i was able to see it's progress by watching the size of the SNAR file steadily increase, and now it has moved on to the other incremental backups.

will report back if there are any further issues

taka khumbartha (scar) said : #5

just wanted to add that creating the SNAR file takes a VERY long time. the time it takes seems to be proportional to the size of the backup, as the incremental backups converted rather quickly but the full backup took about 44 hours. the full backup was a paltry 4.2 GB. i can't imagine what it would be like to convert the backups i have of the datacenter (~700 GB).... if the process is linear, i figure that would take about 305 days to complete.

therefore, i would highly recommend that users upgrade to the 0.11 version of sbackup and start taking backups which will be created using the v1.5 snapshot, rather than having to go through this upgrade process (which i am needing to do in order to correctly 'revert'). though, if you're reading this here and now, it's probably too late. perhaps this information could be put someplace more prominent...

The conversion was long also for me but not as much as that. As far as I can remember, it took around 2/3 hours for a 12GB backup

Thomas L. (tjl) said : #7

I got exactly the same problem ([Errno 2] No such file or directory: 'file:///media/4A43-0B5E/throne/2010-10-16_03.33.56.248402.throne.ful/files.snar') when trying to use the gtk gui; I found a workaround which seems to be working for my by changing a line in the source - see my bug report #1000896.

I also experience the "painfully slow issue" as reported by Francesco Potortì in #1000171.

Can you help with this problem?

Provide an answer of your own, or ask niewo for more information if necessary.

To post a message you must log in.