Implicitly excluded directories may be confuisng.

Asked by Liam O'Reilly on 2010-09-03

I started to play with sbackup as I was looking for a tool to replace my current backup system. Sbackup looks very much like the tool for the job. However when testing it, I tried to backup the directory /tmp/ with no exclusions.

I cannot run sbackup on my home directory as I use NFS and root squash was is in effect, thus I thought /tmp will change a little over time and would be a fair choice to play wth sbackup over a few hours and see how it works.

After running a few backups, I noticed in the restoration system that no files were backed up. This confused me for a while, until I found the file excludes.list in the most recent backup. This file indicates to me that the following directories are never backed up:
/sys/*
/tmp/*
/proc/*
/dev/*
<target directory of backup>

I found this a little disturbing - whilst completely understanding why these exclusions were forced. I made sure the exclude list was empty and I thought nothing was being excluded. I like to fully understand my tools, especially for a job like backup. Finding that certain directories were excluded after I was told (via the GUI) that nothing was to be excluded and only /tmp was to be backed up, undermined my confidence in the tool a little. What if sbackup was doing other stuff that I didn't agree with and did not tell me and I had yet to find out or notice?

I think the tool (the GUI) should be upfront about such exclusions. Possibly by not allowing you to delete them from the exclusions list.

Does anyone else think this is an issue or am I just being pedantic?

Question information

Language:
English Edit question
Status:
Solved
For:
sbackup Edit question
Assignee:
No assignee Edit question
Solved by:
Liam O'Reilly
Solved:
2010-10-02
Last query:
2010-10-02
Last reply:
2010-10-02
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Liam O'Reilly (aliam13-2) said : #2

Is anyone reading this, or is there just no input off anyone?

Jean-Peer Lorenz (peer.loz) said : #3

Hello Liam,

no, you're absolutely right and this is already on 'a' long-term todo list:
* pre-defined settings must be displayed/reflected in user interface
* a way should exist to enable users to modify such pre-defined settings (e.g. GConf values, advanced settings tab etc.)
Please file a bug for this issue and post your findings and suggestions there so we keep it in focus.

Thanks for using SBackup and helping to make it better.

Liam O'Reilly (aliam13-2) said : #4

Hi Jean-Peer Lorenz,

Thanks for your answer.

I will file this as a bug (and one or two other improvements that I think will really make the project better).

All the best
Liam