Package for Ubuntu 16.04 LTS

Asked by buhtz

Hi,
is there a plan to release a package for samsung-tools for Ubuntu 16.04 LTS?

Question information

Language:
English Edit question
Status:
Solved
For:
Samsung Tools Edit question
Assignee:
No assignee Edit question
Solved by:
Fortunato Ventre
Solved:
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :
#1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
buhtz (buhtz) said :
#2

Reopen.

Revision history for this message
Best Fortunato Ventre (voria) said :
#3

Sorry for the late answer.
No, there is no plan.
I've been away from ubuntu for a while now.
Is samsung-tools of any use yet? I think a lot of things have changed, and most of the functionalities provided by samsung-tools would need a complete revisit.
Also, since my old crappy Samsung netbook is almost dead, I really have no interest in keeping this work on. Right now the only useful functionality from samsung-tools in my opinion is the keybindings, which is of a limited use anyway since any good modern desktop environment already provides bindings for wifi toggling, bluetooth toggling etc.

Revision history for this message
buhtz (buhtz) said :
#4

Thanks Fortunato Ventre, that solved my question.

Revision history for this message
Sorcerous (sorcerousvenus7) said :
#5

Hi,

I am using a Samsung 300-e5a laptop and the only way wifi and fan control fuction keys work is via installing Samsung-tools on it.
Since the new version is 16.04 , I am unable to install Samsung tools for 16.04. Old packages for oneiric and thrusty don't work either.
People like me and a lot of other people are counting on this project to use their Samsung laptops in Ubuntu.

Thank you very much for your hard work and effort. You really are a hero...

I hope this project will continue because it's a useful project.

Regards

Revision history for this message
buhtz (buhtz) said :
#6

I see it the same way.

Revision history for this message
Marcus (mga0) said :
#7

+1

Confirmed, changed to 16.04 today and the old deamons are back.
Fan control, backlight adjustment and wifi toggle not working on my Samsung R580. Any workarounds for one of them known?

Thanks for your work in the past voria! Appreciate samsung-tools since 10.04!

Revision history for this message
Sorcerous (sorcerousvenus7) said :
#8

hi guys,

Is there any way linux on my samsung project could continue elsewhere given the fact that Voria is not interested in
continuing development of samsung-tools for 16.04. Could someone else carry on this project and compile code for 16.04?

Thanks

Revision history for this message
Mystic-Mirage (mystic-mirage) said :
#9

Hi!

I've rebuilt the latest version of Samsung Tools (2.3.1 from Trusty) for Xenial -- https://launchpad.net/~mystic-mirage/+archive/ubuntu/loms. No changes to the code -- just add one dependency and remove obsolete build time option.

Regards

Revision history for this message
Sorcerous (sorcerousvenus7) said :
#10

@Mystic-Mirage

Thank you very much for the samsung-tools 16.04 version.
I installed it and it works like a charm.
We, people who use opensource software are thankful for your efforts and support that you put into projects like this one.
Big respect.

Also @Voria, thanks for creating this project and enabling people use samsung laptops properly in Ubuntu.

You both are heroes!

Revision history for this message
Marcus (mga0) said :
#11

Works for me like a charm, too. Finally I can decrease the fan noises of my little lawn mower.
Thank you a lot @Mystic-Mirage

Umm, well, besides of that: My screen on R580 can't change its brightness. Anyone else?

Revision history for this message
Miguel Eduardo Muñoz Palma (miguelmunozp) said :
#12

Mystic-Mirage
fantastic , thank you very much , finally I can control my samsung 530U3C and wifi switch, thanks total, also to Voria

Revision history for this message
Tatu Aalto (digitalta) said :
#13

Mystic-Mirage
Thank you! I spent quite a while fiddling about with a tablet I bought used, trying kernel options like acpi_backlight=vendor and so on. For whatever reason installing the xenial version of the tools package is what finally made /sys/class/backlight/samsung appear and as such enable the backlight brightness control. For reference (and so that search engines find this page for anyone else looking), the model is Samsung ATIV Smart PC Pro XE700T1C

Revision history for this message
Fortunato Ventre (voria) said :
#14

I just released a new minor version (2.3.2) of Samsung Tools, in order to support most modern ubuntu versions. More info and discussions at: http://loms.voria.org/.

PS: Thanks to Mystic-Mirage for his work!

Revision history for this message
Sorcerous (sorcerousvenus7) said :
#15

Hey thanks!!! Thats great to hear. So is it going to work with the next ubuntu LTS release in April?
Im still using my 5 yr old samsung with an ssd in it. Works like a charm on Ubuntu!

Thanks

Revision history for this message
Mystic-Mirage (mystic-mirage) said :
#16

Hi, Voria! Also look at here -- https://code.launchpad.net/~mystic-mirage/+recipe/samsung-tools-mm for example of auto build from git repo. It can dramatically save your time. I recommend using more plain versions in debian/changelog for auto build -- like 2.3.2-1. Just remove tilda-staring parts. Place them in auto build recipe.

Revision history for this message
Fortunato Ventre (voria) said :
#17

I don't see the point for auto build, I don't expect that much of activity on the git repo since the project is in maintenance mode.
About the versioning, it's a good practice directly from the ppa versioning guidelines, since the built package can be used on any debian-based distro and this way is easily superseeded by distro's specific packages.

Revision history for this message
Mystic-Mirage (mystic-mirage) said :
#18

Hey, @voria! Can you build the package for upcoming Ubuntu 18.04 release, please?

Revision history for this message
Fortunato Ventre (voria) said :
#19

Done, the package will be available shortly on the 'Linux On My Samsung' repository.

Revision history for this message
Giordano (giowi) said :
#20

It doesn't work on lubuntu 18.04 64bit for samsung n150 plus

Revision history for this message
Mystic-Mirage (mystic-mirage) said :
#21

Hi!

What kind of problem are you facing? You can't install Samsung Tools or can't run it? Samsung Tools works perfectly on my N148 Plus with Xubuntu 18.04 installed.

Revision history for this message
Giordano (giowi) said :
#22

@Mystic-Mirage (mystic-mirage)
I installed Samsung tools both with terminal (sudo add-apt-repository ppa:mystic-mirage/loms
sudo apt-get update) and with deb file,but nothing works. I use fn+ (f3,f4,f5 etc etc) but nothing happens.
Can you help me?

Revision history for this message
Mystic-Mirage (mystic-mirage) said :
#23

First of all, you should use Samsung Tools from official PPA -- ppa:voria/ppa
Second, ensure if samsung-tools-preferences can be launched without any problem.
Third, check if Samsung Tools is enabled in session autostart.
If all seems fine, run /usr/share/samsung-tools/session-service.py in terminal and check if there is no tracebacks appeared.

Revision history for this message
Giordano (giowi) said :
#24

Just installed Ubuntu 18.04 64 bit. It works!!!
But it's not compatible with lubuntu 18.04

Revision history for this message
Giordano (giowi) said :
#25

Just installed Xubuntu 18.04 64 bit. It works!!!
But it's not compatible with lubuntu 18.04