How can I set a default input method?

Asked by Aku on 2012-06-14

I type a lot of Japanese using the IBus input method. Unfortunately, this does not work in sakura by default.

However, I've discovered that if I do "[Right-click] > Options > More > Input methods > X Input Method" every time I start a new sakura window, IBus input will be registered completely correctly. Is there a way to make the X Input Method the default, so I wouldn't have to change it every time?

Surely this is a hugely important feature for a terminal emulator named after the cherry blossom, a symbol of Japan? ;)

Question information

Language:
English Edit question
Status:
Solved
For:
Sakura Edit question
Assignee:
No assignee Edit question
Solved by:
David Gómez
Solved:
2012-07-10
Last query:
2012-07-10
Last reply:
2012-06-15
Best David Gómez (dabisu) said : #1

Sure it is. I also type in japanese often.

The default input method is not determined by sakura, but by the configuration of your system. In my system IBus is the default.

Why are you selecting XIM? Isn't there an "System (IBus)" option in the menu?

Aku (akuwizard) said : #2

I only see "System (Simple)" in the menu. No "System(IBus)" on the list. Seems like a problem at my end.

For the 3 hours since your reply I've been looking for a solution without success. IBus works as expected in Luakit, Firefox and Truecrypt, but not in Skype or Sakura. Skype can of course be disregarded for being a mess to begin with, which leaves Sakura.

Would you (or others) have pointers to give or a working config to show?

--

Here's what I do:

My ~/.xinitrc runs the IBus daemon as

ibus-daemon --xim -d

and the IBus tray icon appears correctly once my window manager starts. I also set these relevant environment variables in my ~/.bashrc just in case:

# Keeping ibus happy
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus
export XIM_PROGRAM=/usr/bin/ibus-daemon
export XMODIFIERS=@im=ibus

Not even sure if all of those are necessary. They're from the Arch Linux wiki and various blog sources. A further suggested env var "export GTK_IM_MODULE_FILE=/etc/gtk-3.0/gtk.immodules" just broke everything, so I ditched it immediately. I'm desperate, see!

I've tried starting ibus-daemon both with and without the --xim flag. Other than those documented here, I've made no changes to system config. The same problem persists; Sakura has no "System (IBus)" in the menu but works if I select "X Input Method".

David Gómez (dabisu) said : #3

sakura doesn't add or remove entries in the list of input methods, they're already there.

Do you have the im-switch application instaled? Try to set the default input method (in your case XIM, because there is no System(IBus) using that application.

Aku (akuwizard) said : #4

The problem magically disappeared in one of my last "pacman -Syu" system updates. I always check what is being updated and did not notice Sakura being part of these updates, so the problem must have been elsewhere. I wish I had noticed sooner so I could localise the problem better.

"System (IBus (Intelligent Input Bus))" is now the default selected input method. Activating the Anthy input method inside Sakura now works as expected, without the need to change any further settings.

Thanks for your help, David! :)

Aku (akuwizard) said : #5

Thanks David Gómez, that solved my question.