underlying interface name is mandatory

Asked by sokrate on 2013-08-08

Hello

I installed iprohc 0.7 and ROHC library 1.6.0, created config file /etc/iprohc_server.conf whith next:
general:
    port: 3126
    pidfile: /var/run/iprohc_server.pid
    p12file: /etc/ssl/server_voip.p12
tunnel:
    ipaddr: 192.168.42.1
    packing: 5
    maxcid: 15
    unidirectional: 1
    keepalive: 60
and when i start iprohc_server i get in syslog next:
Aug 8 18:39:31 lb iprohc_server[14314]: underlying interface name is mandatory
Aug 8 18:39:31 lb iprohc_server[14314]: server stops with exit code 1
Aug 8 18:39:31 lb iprohc_server[14314]: close syslog session

thanx for any help

Question information

Language:
English Edit question
Status:
Solved
For:
rohc Edit question
Assignee:
No assignee Edit question
Solved by:
Didier Barvaux
Solved:
2013-08-09
Last query:
2013-08-09
Last reply:
2013-08-09

Hello,

You need to specify the name of the network interface on which the tunnel will send its packets with the --basedev or -b option. The given network interface is used to detect the link MTU and compute the MTU of the tunnel.

I will soon update the source code to make the message clearer:
     wrong usage: underlying interface name is mandatory,
     use the --basedev or -b option to specify it

This modification will be shipped with the 0.8 release.

Regards,
Didier

sokrate (dariimaxim) said : #2

how add this option in config file?

sokrate (dariimaxim) said : #3

when i start client
iprohc_client --b eth0 --remote 192.168.2.69 --port 3126 --dev iprohc --p12 /etc/ssl/server_voip.p12
i get:
iprohc_client[2002]: failed to connect to server: No route to host

both clients are located in same network

sokrate (dariimaxim) said : #4

and when try to do
telnet 192.168.2.69 3126

from any host excluding localhost I get same message
telnet on 22 port works

sokrate (dariimaxim) said : #5

sorry i forgot about firewall rules, now ok

how i can add option -b in config file?

> how i can add option -b in config file?

That's not an option in config file, but a command line option for the iprohc_server/iprohc_client binaries.

Regards,
Didier

sokrate (dariimaxim) said : #7

Thanks Didier Barvaux, that solved my question.

> I will soon update the source code to make the message clearer:
> wrong usage: underlying interface name is mandatory,
> use the --basedev or -b option to specify it
>
> This modification will be shipped with the 0.8 release.

FYI, I pushed the modification in the public branch at revision 112.

Regards,
Didier