Does Rhythmweb work with rhythmbox 2.90.1?

Asked by Boyd on 2012-05-07

I can't get this plugin to show up in Rhythmbox 2.90.1. To be honest, I'm rather confused by the rhythmbox version numbering. I've tried placing files in the /usr/lib/rhythmbox/plugins and in ~/.gnome2/rhythmbox/plugins but I can't even get them to show up.

Question information

Language:
English Edit question
Status:
Answered
For:
Rhythmweb Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-07
Last reply:
2012-09-18
Ryan Kitty (gothickitty93) said : #1

If this doesn't get a response within the next day I'm going to convert this to a bug. Rhythmbox is placing all of it's custom added plugins in "~/.local/share/rhythmbox/plugins/" At least, it did when I compiled one from source. That one worked. Anyway, from what I have gathered, Rhythmbox has changed the way it's plugins are created, as I am seeing .plugin for all plugins, but rhythmweb is a .rb-plugin. Seems to me the code needs to be updated. I could very well be totally wrong though, as I'm not really familiar with Rhythmbox.

nUboon2Age (nuboon2age) said : #2

I'm getting the same result with Ubuntu 12.04.1 LTS and Rhythmbox 2.97 so I agree that this is a bug and no it does not seem to be working. Thank you Ryan for reporting your investigation into why it might not be working!

fossfreedom (fossfreedom) said : #3

I've got a working GTK3 rhythmbox rhythmweb plugin in my GitHub repo which I know works with v2.96 & v2.97 Rhythmbox.

Hope this helps.

https://github.com/fossfreedom/rhythmweb

Can you help with this problem?

Provide an answer of your own, or ask Boyd for more information if necessary.

To post a message you must log in.