couldn't install in ubuntu karmic

Asked by saravanan on 2010-01-13

Hi. I tried installing Rescuetime in ubuntu karmic. the firefox extension was installed. but i could not access preferences button from addon.

Also when i used the "sudo python setup.py install" command, i received the following msg.

"Installed /usr/local/lib/python2.6/dist-packages/RescueTimeUploader-unknown-py2.6.egg
Processing dependencies for RescueTimeUploader==unknown
Finished processing dependencies for RescueTimeUploader==unknown"

is it installed properly? if not, how to install correctly.
If its installed, how to get it working?

Help me guys..

Question information

Language:
English Edit question
Status:
Answered
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-13
Last reply:
2010-02-24
Piotr Kilczuk (p-kilczuk) said : #1

Hello,

Sorry for late answer.

Yes, I guess it is installed correctly. There is a bug related to setuptools which I'll have to fix asap. Currently being busy with 2+ large project it is kind of impossible.

Anyway, if you can run rescuetime_linux_uploader from console, it means, that RTLU installed correctly. Just enter your credentials now.

Then run:
gnome-session-properties
and add rescuetime_linux_uploader to be launched on every login of current user.

From now on your data should be reported to RescueTime.com. Don't forget to install Firefox extension if you use that browser.

Good luck,
Piotr

thanks, this helped, BUT:

now rescuetime uploader (as seen from the command line) sends the data to the rescuetime.com server
----
Logging in...
login success!

Uploading data...
Uploading 6.upload.encoded.data ...
<hash><successes>7</successes><total-records>7</total-records></hash>
------

but there is nothing in the dashboard. What could be the problem?

I am was getting the same problem, when i run the command "rescuetime_linux_uploader" the data start to be processed, but nothing was on the dashboard of the RescueTime.

I think misteryolis some ubuntu updates make the rescue time linux data collector work well, i dont know how but i am was posting a massage here to show the same problem but now the are data at dashboard.

I dont know how it happens, but i am glad its working, thank very much for work at this project.

Francisco Matelli

Piotr Kilczuk (p-kilczuk) said : #4

I'd incline to towards RescueTime bug. Answer from RescueTime guys didn't explain much except for the fact, that they cannot recover that 'accepted' data themselves. For me it works now in several environments.

P.S. If you need past data:

1. Go to ~/.rescuetime/finished (for example /home/piotr/.rescuetime/finished)
2. Move revelant files to ~/.rescuetime/prepared (you have to check dates yourself)
3. Wait for next scheduled upload and check your dashboard

This should work.

Can you help with this problem?

Provide an answer of your own, or ask saravanan for more information if necessary.

To post a message you must log in.