add the RescueTime Applet error

Asked by LEO on 2009-05-01

system : ubuntu 9.04
i download the rescuetime-linux-uploader-93 and install follow this command:
Run "python setup.py build" then "sudo python setup.py install" to use setuptools to install the program. It will install a script into /usr/bin/rescuetime_linux_uploader that allows you to run the executable from the command line. It will also install the gnome panel applet.

To run from the command line:
 Run "rescuetime_linux_uploader" and follow the instructions to enter your username and password. These will be stored in $HOME/.rescuetime/preferences, should you need to change them.

To add to your gnome panel:
 Right click on your gnome panel, click "Add to Panel..", and select "RescueTime" from the "Utility" section. Fill out your username and password, if necessary.

when i run this command "rescuetime_linux_uploader", it's ok, i can log in. but when a add the rescue time applet, it is error , it display that:The panel encountered a problem while loading "OAFIID:GNOME_RescueTimeDurationApplet".
i don't why?
somebody can help me?

Question information

Language:
English Edit question
Status:
Answered
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-03
Last reply:
2009-10-08
Rudolf Meijering (skaapgif) said : #1

Hi LEO,

I got the same problem. A little investigation showed that the applet looks for rescuetime_linux_uploader_gnome_panel_notifier in /usr/bin/ while the installer put that file in /usr/local/bin/

FIX: Edit rescuetime_notifier.server and rescuetime_tracker.server inside the gnome-applet folder.

In the third line change: "/usr/bin/..." to "/usr/local/bin/"

i.e. rescuetime_notifier.server would become: "/usr/local/bin/rescuetime_linux_uploader_gnome_panel_notifier"

Hope that helps and that someone would fix this...

Rudolf Meijering (skaapgif) said : #2

I forgot to add... after the above changes build and install again and it should work...

LEO (leo85726) said : #3

thank you for your help. but the problem isn't solved. i changed: "/usr/bin/..." to "/usr/local/bin/", and checked the files "rescuetime_linux_uploader_gnome_panel_notifier" and "rescuetime_linux_uploader_gnome_panel_controller". there are in /usr/local/bin/ . i think your method is right, but i don't know why the problem is still exist?

Hmm...I'm seeing this issue as well, but those apps are in /usr/bin just like the .server files are expecting. Cmd-line app works, as does the Ffx extension (once I built it, which the main README didn't mention, btw). But the gnome panel applet doesn't want to cooperate.

Oops...didn't realize I was "answering" the question, as I obviously didn't.

Rafael Beckel (rafaelbeckel) said : #6

I resolved this creating hardlinks inside /usr/bin for the softwares localized in usr/local/bin. No need to rebuild it.

Zac Zheng (zac-zenpow) said : #7

Thanks Rafael! That resolved it for me. Thanks to sKAApGIF as well for finding the issue.

Can you help with this problem?

Provide an answer of your own, or ask LEO for more information if necessary.

To post a message you must log in.