Login failed

Asked by Erwin on 2008-03-12

Hi,

I installed the uploader on my Mandriva box. The script runs but fails to log me on. I am using the complete email address and the correct password. Any ideas?

Thx.

Question information

Language:
English Edit question
Status:
Solved
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Solved by:
Erwin
Solved:
2008-05-07
Last query:
2008-05-07
Last reply:
2008-03-27
Angus Helm (angus.helm) said : #1

Are you using the gnome panel applet or the command line? Could you try removing your ~/.rescuetime/preferences file and running the command line script "rescuetime_linux_uploader", and see what it prints out?

Erwin (erwin-feldhaus) said : #2

I am using the command line. I also tried the applet, but same result. I deleted the preferences file (which was empty) and ran the script again. Same result:

[xxx@yyy ~]$ rescuetime_linux_uploader
finished initing module!
hi from process 4017
starting init!
Your rescuetime username: <email address hidden>
Your rescuetime password:
Logging in...
Login failed.
Your rescuetime username:

Angus Helm (angus.helm) said : #3

Can you try with version 63? It looks like a network problem, which in version 60 was silenced. The latest version should print out the problem.

Erwin (erwin-feldhaus) said : #4

I have now tried it. Here is the output:

Traceback (most recent call last):
HTTPError: HTTP Error 501: Not Implemented
Login failed.

Angus Helm (angus.helm) said : #5

That is extremely odd, and I have no idea what is going on. I'll look into it this weekend. What OS version and Python version are you running, btw?

Erwin (erwin-feldhaus) said : #6

I am using Python 2.4.3 on Mandriva 2007.0

Angus Helm (angus.helm) said : #7

I've tried testing with Python2.4 to see if its urllib uses a GET instead of a POST or something, but I'm not seeing anything. A 501 error would indicate something server-side, so I've sent off an email to the rescuetime team to see if they can figure anything out.

Angus Helm (angus.helm) said : #8

Could I get your email address you are using to login, btw? You can email it to me at angus at angushelm dot com if you don't want it public. The RescueTime guys need it to grep their logs and see if they can find the problem.

Angus Helm (angus.helm) said : #9

Alright, they looked through their logs and didn't find anything. Our best guess at the moment is that you have an unusual character in your password that isn't being encoded correctly.

Erwin (erwin-feldhaus) said : #10

That would be strange... I only use letters and numbers in my password. And then, it would cause a problem when logging on in Windows, for example.

Angus Helm (angus.helm) said : #11

Not if the windows and linux uploaders encoded the password in two different ways.

Hmm. The only thing I can think of is if you're on a corporate box with a proxy or firewall or some other kind of protection.

This seems to be a similar problem, involving a proxy: http://mail.python.org/pipermail/python-list/2007-June/447252.html I thought urllib2 automatically set up proxy information, but it may not.

Erwin (erwin-feldhaus) said : #12

That could be possible. I am using Squid here. Would you have any idea as how to circumvent this?

Angus Helm (angus.helm) said : #13

I am extremely sorry that I did not get back to you sooner on this.

Could you try adding the following to the top of the uploader.py file:

http://mail.python.org/pipermail/python-list/2007-June/447323.html

It should go after the import statements but before the rest of the code. You'll need to reinstall after the change. I'm not completely sure, but I believe setuptools may not reinstall it correctly, and you'll have to edit the setup.py script to add .1 to the version.

Erwin (erwin-feldhaus) said : #14

Now it is my turn to apologize for not responding earlier...

Finally I ended up upgrading (overdue) my OS. Now on Mandriva 2008.1.

The app installs and works fine... except for a small detail that I will post on a new thread.

Thanks.