/bin/sh: 1: /usr/local/lib/python2.7/dist-packages/RescueTimeUploader-unknown-py2.7.egg/RescueTimeUploader/extensions/Firefox/extended_info: Permission denied

Asked by Sandy Walsh on 2012-05-24

I keep seeing this message showing up in the console.

/bin/sh: 1: /usr/local/lib/python2.7/dist-packages/RescueTimeUploader-unknown-py2.7.egg/RescueTimeUploader/extensions/Firefox/extended_info: Permission denied

I installed the RescueTime addon as suggested in the README

Ubuntu 12.04

Suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Solved by:
Dirk T
Solved:
2012-05-24
Last query:
2012-05-24
Last reply:
2012-05-24
Sandy Walsh (sandy-walsh) said : #1

Hmm, ok, perhaps I misread the README.

I uninstalled the stock RescueTime addon and attempted to add the Firefox extension included in this package.

Doesn't work with Firefox 12 :(

Any updates on this?

Best Dirk T (miriup) said : #2

chmod a+x /usr/local/lib/python2.7/dist-packages/RescueTimeUploader-unknown-py2.7.egg/RescueTimeUploader/extensions/Firefox/extended_info

... will get rid of the message.

However, on my machine the Firefox extension is incompatible with the Firefox 12 as it comes with Ubuntu. Which means: you still won't get the web-pages reported. The Firefox extension of this free client will probably not be upgraded anytime soon.

Rescuetime is having a beta version of their own client in their forums. The last time I tried it didn't run on Ubuntu x86. But they are developing on Ubuntu I think and you may get lucky.

Check out:
http://help.rescuetime.com/login?to=%2Fdiscussions%2Fbeta%2F7-rescuetime-for-linux-beta-tester-feedback

Sandy Walsh (sandy-walsh) said : #3

Thanks ... it doesn't get rid of the message, but I'm not going to worry about it if there's potentially a replacement.

I'll try the other package.