Ubuntu 10.04 install troubles

Asked by Jacob Alheid on 2010-07-23

I thought I'd post a question first before filing a bug - just downloaded release 99 today and had no troubles w/ build & install. However...

Both gnome applets (Controller and Information) error when I attempt to add them to my panel with generic-ish messages...
** Just noticed someone already posted on this in bug #605142.

I tried the command-line version also, however I get a sneaking suspicion that since I use my google account to sign in it won't work for me ... But my google username/email and pass definitely didn't work.

Finally, I tried applying the patch (before building...) for google chrome support (bug #606956) and it failed with this:
patching file extended_info
patching file uploader.py
Hunk #1 FAILED at 175.
1 out of 1 hunk FAILED -- saving rejects to file uploader.py.rej
patching file background.html
patching file manifest.json

So I don't know if that's a version problem (e.g. I should be on 98 instead of 99, or have already patched that file once) or some magical new fun stuffs.

Anyway, love the app, so I'd love to get it working if it's possible, if someone might help me. :)

Question information

Language:
English Edit question
Status:
Answered
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Last query:
2010-07-23
Last reply:
2010-10-13
Joseph Lisee (jlisee) said : #1

That was my Google Chrome support patch. It should apply cleanly to version 99, but because I am working on several local changes, and I am not super familiar with Bzr I could of made a mistake. I will try attempt to patch a clean version myself to see if it works.

Does the solution posted by Ray Stuart work:

"My solution was to edit these two rescuetime .server files...

/usr/lib/bonobo/servers/rescuetime_tracker.server
/usr/lib/bonobo/servers/rescuetime_notifier.server

and edit the location in the third line of each from "/usr/bin/rescuetime..." to "/usr/local/bin/rescuetime..."

This is on Lucid 32-bit, but might be the same issue you are having."

Ray's fix does not work for me on 10.04, I can't find the files "rescuetime_linux_uploader_gnome_panel_controller" and "rescuetime_linux_uploader_gnome_panel_notifier" that the .server files reference.

I do however get these errors when I build and install (same for build and install):

bzr: ERROR: Not a branch: "/home/sheldon/Desktop/rescuetime-linux-uploader-99/".
/usr/lib/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option: 'entry_points'
  warnings.warn(msg)

Sven Bendel (ubuntudroid) said : #3

At least I have found a solution to your login problem on the command line. You have to simply click on "change password" here (https://www.rescuetime.com/users/settings) and then enter a password you like. Then try to login via terminal again with your email address and the password you've just chosen. And there you go! :)

However I also had this bzr error when building and installing. But it seems that this is no real problem.

The gnome-applets both me the generic error message, too. I would be very interested in a fix...

Sven Bendel (ubuntudroid) said : #4

Applets problem solved! Simply make hardlinks after the installation:

sudo ln /usr/local/bin/rescue* /usr/bin/

Did it for me!

Can you help with this problem?

Provide an answer of your own, or ask Jacob Alheid for more information if necessary.

To post a message you must log in.