problem with downloading setuptools version 0.6c8

Asked by saravanan on 2010-05-26

could not install rescue time because of the following error

saravanan@saravanan-laptop:~/Desktop/rescuetime-linux-uploader-98$ python 2.6
python: can't open file '2.6': [Errno 2] No such file or directory
saravanan@saravanan-laptop:~/Desktop/rescuetime-linux-uploader-98$ python
Python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
saravanan@saravanan-laptop:~/Desktop/rescuetime-linux-uploader-98$ python setup.py build

---------------------------------------------------------------------------
This script requires setuptools version 0.6c8 to run (even to display
help). I will attempt to download it for you (from
http://pypi.python.org/packages/2.6/s/setuptools/), but
you may need to enable firewall access for this script first.
I will start the download in 15 seconds.

(Note: if this machine does not have network access, please obtain the file

   http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c8-py2.6.egg

and place it in this directory before rerunning this script.)
---------------------------------------------------------------------------
Downloading http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c8-py2.6.egg
Traceback (most recent call last):
  File "setup.py", line 2, in <module>
    ez_setup.use_setuptools()
  File "/home/saravanan/Desktop/rescuetime-linux-uploader-98/ez_setup.py", line 107, in use_setuptools
    return do_download()
  File "/home/saravanan/Desktop/rescuetime-linux-uploader-98/ez_setup.py", line 85, in do_download
    egg = download_setuptools(version, download_base, to_dir, download_delay)
  File "/home/saravanan/Desktop/rescuetime-linux-uploader-98/ez_setup.py", line 146, in download_setuptools
    src = urllib2.urlopen(url)
  File "/usr/lib/python2.6/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.6/urllib2.py", line 397, in open
    response = meth(req, response)
  File "/usr/lib/python2.6/urllib2.py", line 510, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.6/urllib2.py", line 435, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.6/urllib2.py", line 369, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.6/urllib2.py", line 518, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found

tried downloading from the website directly. but 0.6c8 was removed. downloaded 0.6c9 and 0.6c10 of the setup file. but the script did not recognize.

Question information

Language:
English Edit question
Status:
Answered
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-26
Last reply:
2011-11-21
meistercobbman (cobbman) said : #1

I don't know much about python, but I was able to change the ez_setup.py file on line 17 to point to the right file on the server.

DEFAULT_VERSION = "0.6c11"

instead of "0.6c8"

Though it made the install work, the applet for linux does not work - though it does show up in the "Add to Panel..." list.

What can I say, I'm a newb.. but I think this is a step in the right direction.

Looks like a simple error that should be fixed soon by the guru's who are already on this project.

Please fix soon!!!

Thanks :)

Piotr Kilczuk (p-kilczuk) said : #2

Changed, can you pls confirm it works the proper way now?

meistercobbman (cobbman) said : #3

The auto download works when running "python setup.py build", and it appears to work after running "sudo python setup.py install". However, the applet still does not function when trying to add it to the panel (as we're instructed to do in the readme file).

The only way I was able to get it to run is by running the "test" file in the terminal. Then suddenly the .rescuetime folder finally showed up in my HOME folder. It also asked for my rescuetime usrnm and password and successfully logged in.

Lastly, typing rescuetime_linux_uploader in the terminal only results in "command not found." So the only way I can see running rescuetime is by running the test file. Is that right?

I'm basing everything off of the README file and the directions it gives.

Let me know if there is any additional information you need.

sajid ali (sajidalimudassar) said : #4

I tried to follow this tut:
http://ubundance.blogspot.com/2010/08/installing-rescuetime-on-ubuntu-1004.html

Step 5 does now work, as
rescuetime_linux_uploader in the terminal results in "command not found."

so I am having same issue as #3. Using ver 99 of rescuetime_linux_uploader

sajid ali (sajidalimudassar) said : #5

Update:
I have run this
sudo apt-get install python-setuptools

and after that, running this command works without any errors
sudo python setup.py install

Now rescuetime_linux_uploader file is shown in
/usr/local/bin

and now this also works
sudo ln /usr/local/bin/rescue* /usr/bin/

so you can follow the tutorial (link posted in comment #4) after installing python-setuptools

Can you help with this problem?

Provide an answer of your own, or ask saravanan for more information if necessary.

To post a message you must log in.