Can't find /usr/bin/rescuetime_linux_uploader

Asked by Dobre Catalin on 2010-05-01

Had some problems with the command "python setup.py build" I was getting a 404 Error , I changed a filed in ez_setup.py DEFAULT_VERSION = "0.6c8" to DEFAULT_VERSION = "0.6c9" and it worked.
After that "python setup.py install".

I got the fallowing output:

/usr/lib/python2.6/distutils/dist.py:266: UserWarning: Unknown distribution option: 'entry_points'
  warnings.warn(msg)
running install
running build
running build_py
running install_lib
running install_egg_info
Removing /usr/local/lib/python2.6/dist-packages/RescueTimeUploader-unknown.egg-info
Writing /usr/local/lib/python2.6/dist-packages/RescueTimeUploader-unknown.egg-info

After this i looked for resuctime_linux_uploader in /usr/bin and didn't find it...

I want to mention that I am using now Ubuntu 10.04 and had no problems on Ubuntu 8.04 when I first installed it.

What might be the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
RescueTime Linux Uploader Edit question
Assignee:
No assignee Edit question
Solved by:
briancgraham
Solved:
2010-05-16
Last query:
2010-05-16
Last reply:
2010-05-11
Piotr Kilczuk (p-kilczuk) said : #1

Isn't it rather /usr/local/bin/rescuetime_linux_uploader ?

Piotr Kilczuk (p-kilczuk) said : #2

Isn't it rather /usr/local/bin/rescuetime_linux_uploader ?

Dobre Catalin (catalynd1) said : #3

/usr/local/bin is empty

Dobre Catalin (catalynd1) said : #4

I still didn't solved the problem , I am spending most of my time on linux now and already lost a full week of data :(.
Are there any other sugesstion ? As I mentioned before on Ubuntu 8.04 it worked , is there anybody who managed to install it on Ubuntu 10.04 ?

briancgraham (briancgraham) said : #5

i had to do a few things

1) download the latest version of setuptools-0.6c11-py2.6.egg into the same folder you're trying to run setup.py from
* setup.py will still look for the old version, soooo

2) replace the ez_setup.py file with this one replacing ez_setup.y with the latest version from:
http://peak.telecommunity.com/dist/ez_setup.py

3) now install the setuptools-0.6c11-py2.6.egg => sudo sh setuptools-0.6c11-py2.6.egg

4) now run sudo python setup.py build AND sudo python setup.py install

at this point you can run the start script of rescuetime_linux_uploader and you should be prompted for your login id and password

*Thats as far as I've gotten so far... I'm still working on the GNOME panel buttons...

briancgraham (briancgraham) said : #6

btw this is on Ubuntu 10.04

briancgraham (briancgraham) said : #7

more.... (from another thread)

...if you can run rescuetime_linux_uploader from console, it means, that RTLU installed correctly. Just enter your credentials now.

Then run:
gnome-session-properties
and add rescuetime_linux_uploader to be launched on every login of current user.

From now on your data should be reported to RescueTime.com. Don't forget to install Firefox extension if you use that browser.

Piotr Kilczuk (p-kilczuk) said : #8

Hi, sorry for ignoring the thread for so long. For me it works perfectly in 10.04, but I'll try a fresh install in the upcoming days to tell you what is necessary.

Dobre Catalin (catalynd1) said : #9

Thanks alot briancgraham setup runs just fine now!

Only one problem left when I choose RescueTime Contorller applet
I get this message

The panel encountered a problem while loading
OAFIID:GNOME_RescueTimeDurationApplet

After running rescuetime_linux_uploader I get , I
am not asked about a username or password and get this instead:

A part of the output:

Gedit (README (~/Applications/rescuetime-linux-uploader-98) - gedit) now focused (Extended info: None)
dobre@dobre-laptop: /usr/local/bin (dobre@dobre-laptop: /usr/local/bin) now focused (Extended info: None)

Reading from your post I guess you are also stucked here...

Best briancgraham (briancgraham) said : #10

Great that means it's working...

Until we get the 'launcher' working... you can do this to make it start automatically

from terminal run
gnome-session-properties
add rescuetime_linux_uploader to be launched on every login of current user.

After about 30min or so you should see your data appear on the site.

Dobre Catalin (catalynd1) said : #11

Thanks briancgraham, that solved my question.

Thank you Brian, your solution fixed my problems too.

BioGeek (jeroen-vangoey) said : #13

Another thanks to briancgraham, your clear instructions helped me as well.

Thanks Brian, it worked for me too.