Remote Desktop Viewer page blank for localhost:5900

Asked by John Rose

On my laptop (ip address with Ubuntu Jaunty, I installed and launched deb helpers 'version' linked to one router (wirelessly). On my netbook (ip address with Ubuntu jaunty Netbook Remix, I installed and launched deb sharers 'version' linked to another router (wired) and set Remote Desktop Preferences to allow view & control. Everything seems to go OK in terms of swapping & confirming the date keys and success is confirmed (on laptop I check the 'Automatic Manage my Firewall' option after it has problem and it's then happy). On my notebook, 'Desktop Being Shared window is displayed). On my laptop, Remote Desktop Viewer launches and shows a tabbed page for localhost:5900 (seems strange connection address?). However, the tabbed page is blank. Any ideas?

I've allowed ports 2112 & 5900 in both Ubuntu firewalls. First router is UPNP enabled and has Services for RemoteHelpAssistant on port 2112 (with firewall rule for LAN ip address and RemoteDesktopViewer on port 5900 (with firewall rule for LAN ip address Second router is UPNP enabled.

Remote Desktop Viewer (i.e. without using Remote Help assistant) works OK when both laptop & netbook are conected to the same (i.e. second) router. Obviously, laptop then has a different LAN ip address (i.e.

Question information

English Edit question
Remote Help Assistant Edit question
No assignee Edit question
Solved by:
John Rose
Last query:
Last reply:
Revision history for this message
Andrew Sayers (andrew-bugs-launchpad-net) said :

You might want to try setting visual effects to "none" in System > Preferences > Appearance on the netbook. Special effects are implemented in a way that don't play nicely with remote desktop, and it'll be a while before we have decent workarounds available.

By the way, "localhost:5900" is the right address - the connection goes into the assistant on your local computer, gets tunnelled through an SSH session, and comes out of the assistant on the other computer. So the remote desktop viewer just sees the local bit.

I'll mark this as answered for now, but please reopen this if visual effects aren't the problem.

Revision history for this message
John Rose (johnaaronrose) said :

I've just checked the netbook. System>Preferences>Appearance already had Visual Effects of None. I again tried localhost:5900 for the address, but no go.

PS I made a typo in my previous message when referring to firewall rule (in router setup) on first router (i.e. linked to laptop) for port 5590 as using LAN ip address of rather than

I'm now going to check whether disabling UPNP on both routers will help followed by trying out enabling of UPNP on both routers & removing port forwarding for port 5590. If I don't post, please assume that neither of these 'setups' helped.

Revision history for this message
John Rose (johnaaronrose) said :

I disabled UPNP on both routers and everything worked OK though mouse control is not ideal. BTW when Remote Help Assistant invokes Remote Desktop Viewer, the tab shows administrator@JohnNetbook where administrator is the Linux user name and JohnNetbook is the Hostname.