Refstack test results on dashboard - Not visible

Asked by Malleshi C N on 2015-08-10

Hi team,

 I uploaded my test results on refstack API server . I can see the list of test results from CLI.
but its not getting listed under "community results" in my dashboard. I changed refstack.conf as below as per the update from catherine.( patch : https://review.openstack.org/#/c/176335/)

test_results_url = http://<refstack APi host>:8000/output.html?test_id=%s

to

test_results_url = /#/results/%s

details:

malli@localhost:~/refstack-client$ sudo ./refstack-client upload .tempest/.testrepository/15.json --url http://<refstack APi host>:8000/
Test results will be uploaded to http://<refstack APi host>:8000/. Ok? (yes/y): y
Test results uploaded!
URL: http://127.0.0.1:8000/output.html?test_id=4d2d3834-c7c9-498d-a815-6873a4zf769r , no output for this in webbrowser.

If I try url in my web browser with http://<Refstack api host?:8000/output.html?test_id=4d2d3834-c7c9-498d-a815-6873a4zf769r
getting 404 not found.

all the results are pointed to URL: http://127.0.0.1:8000... am I missing some details in refstack.conf file to pint to <my API host> ?.

my config.json pointing to {"refstackApiUrl":"http://<refstack APi host>:8000/v1"}.

on dashboard, under 'community results' prompting below message

 "Error retrieving results listing from server: null" ... is firewall blocking my access to test results?

Results are getting stored in my sql DB, but not reflecting on Dashboard.

Thanks
Malleshi CN

Question information

Language:
English Edit question
Status:
Solved
For:
refstack Edit question
Assignee:
No assignee Edit question
Solved by:
Malleshi C N
Solved:
2015-08-11
Last query:
2015-08-11
Last reply:
Malleshi C N (malleshicn) said : #1

Hi team,

I was able to resolve the issue.

Thanks for your support

Regards,
Malleshi CN

Catherine Diep (cdiep) said : #2

Hi Mallenshi,

Good that you are able to resolve the issue. Is it firewall related? Please let us know!

Malleshi C N (malleshicn) said : #3

Hi catherine...

Thank you.. no , It was not related to firewall.. I made teh changes which asked me to do it related to patch https://review.openstack.org/#/c/176335/) . results were still poined to URL: http://127.0.0.1:8000/output.html?test_id=4d2d3834-c7c9-498d-a815-6873a4zf769 . but next day test results were reflected on test_results_url = /#/results/%s.

so i restarted my npm . so everything was started as I expected.

Catherine, a quick question . when we upload a a results , can we make it number of test paased, no of test failed, or blocked .. total executed, what test calls executed in identity? can we add that feature or is it exists?

can we make the dahsboard to display the results for multiple regions?

Please let me know if this feature is already added.. and I want to know some more details of defcore capabilities, target program,required advisory ..... and more in community resluts( any link I can refer)

Thanks
Regards,
Malleshi CN

Catherine Diep (cdiep) said : #4

Hi Hi Mallenshi,

Yep... caching at the client side may be the cause of what you experienced. I am glad that it works for you now.

Regarding displaying failed, flagged (blocked) tests, we are implementing this bug ( https://bugs.launchpad.net/refstack/+bug/1479959 ). A patch will be submitted soon.

David Liu (lzbj) said : #5

Hi Malleshi,

It seems I got the same issue with you, but after reviewed above comments, I was not quite clear about the solution, could you be more specified on it, or is there somewhere I could find a documentation about it? FYI, I run a refstack server instance from eclipse.

Thanks a lot for your help.

Malleshi C N (malleshicn) said : #6

Hi David,

earlier my results were pinted to results were still poined to URL: http://127.0.0.1:8000/output.html?test_id=4d2d3834-c7c9-498d-a815-6873a4zf769 .

I changed in configuration to pint to test_results_url = /#/results/%s. ( as per catherine update)

and also under /root change the port number in package.json 8085 to 8087 or any 808x , if 8085 is already in use.
 If u are changing the port here, U also need to change in configuration file.

Then start the npm, #npm start from /refstack directory.

This is what I have done . let me know if you are still facing the issue. Thanks

Regards,
Malleshi Cn

David Liu (lzbj) said : #7

Hi Malleshi,

Thank you, I resolved the issue, my problem is the I wrongly configured the UI app port, it should be the same as the port of backend in both config.json file and refstack.conf file, but after finish installation by following the steps described in refstack readme.md, we might need some little tweak to the order of some install commands, already suggested to Catherine. Thank you in anyway.