Is there a reason for the python2.5 dependency in Ubuntu 9.04?

Asked by Mihai Capotă on 2009-03-20

Ubuntu 9.04 comes with python2.6, but Referencer tries to install python2.5. Is there a reason for this or is it just a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Referencer Edit question
Assignee:
No assignee Edit question
Solved by:
John S
Solved:
2009-04-06
Last query:
2009-04-06
Last reply:
2009-04-06
John S (jcspray) said : #1

Which package?

On Fri, Mar 20, 2009 at 12:35 PM, Mihai Capotă
<email address hidden> wrote:
> New question #64755 on Referencer:
> https://answers.launchpad.net/referencer/+question/64755
>
> Ubuntu 9.04 comes with python2.6, but Referencer tries to install python2.5. Is there a reason for this or is it just a bug?
>
> --
> You received this question notification because you are an answer
> contact for Referencer.
>

Mihai Capotă (mihaic) said : #2

referencer_1.1.5-1_amd64.deb depends on python2.5 (>= 2.5).
Shouldn't it depend on python (>= 2.5)?

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mihai Capotă (mihaic) said : #4

I rechecked the dependency a second ago. Same situation.
I still need an answer.

Best John S (jcspray) said : #5

No, there's probably not a reason for it to depend on the older version.

On Mon, Apr 6, 2009 at 10:19 AM, Mihai Capotă
<email address hidden> wrote:
> Question #64755 on Referencer changed:
> https://answers.launchpad.net/referencer/+question/64755
>
>    Status: Expired => Open
>
> Mihai Capotă is still having a problem:
> I rechecked the dependency a second ago. Same situation.
> I still need an answer.
>
> --
> You received this question notification because you are an answer
> contact for Referencer.
>

Mihai Capotă (mihaic) said : #6

Thanks John Spray, that solved my question.