Compiling in Debian Wheezy

Asked by Ramiro Pereira de Magalhães on 2013-05-02

Hi guys,

I'm trying to compile referencer version 1.2.0 in Debian Wheezy, and I'm not being able to resolve dependencies gtkmm-utils and glibmm-utils. I'm not really an experienced person in compiling my own C/C++ software. Does anyone have any idea on how to solve those dependencies. It seems that Debian Wheezy does not have them under those package names.

Question information

Language:
English Edit question
Status:
Solved
For:
Referencer Edit question
Assignee:
No assignee Edit question
Solved by:
Ramiro Pereira de Magalhães
Solved:
2013-05-08
Last query:
2013-05-08
Last reply:

Alright, answering my own questing here's a link where you can download the library. It seems it is not yet being distributed in Debian.

http://packages.ubuntu.com/source/lucid/gtkmm-utils

Oh, and you gotta compile that on your own too, but for me it was pretty straightforward.

Also, I while compiling it could not find Python.h. Had to edit file PluginManager.h, PluginManager.C, PythonDocument.h, PythonPlugin.C and main.C to change the #include <Python.h> to #include <python2.7/Python.h>.

Also, on file PythonDocument.C I had to change the reference for structmember.h to #include <python2.7/structmember.h>.

Now I'm having linking problems.

At last, the linker command is missing the inclusion of python. Adding -lpython2.7 to it solved the problem.

So, you think I should file a bug report for all that? I believe that at least the python reference in the linker command is a bug. I'm not sure if you're interested in having this thing compiling for Debian... In my opinion, you should! :-)

Mads Chr. Olesen (shiyee) said : #5

Please file a bug, preferable with a patch. I'm compiling on Ubuntu 12.10 myself, not sure why the difference is so big.
I think the gtkmm-utils might be a "lesser used package", not sure why it's not in Debian.

Regarding linking to python, my linker line includes "-lpython2.7". It might be because you have multiple Python versions installed, and configure is picking up version 3.0 or something?

Yes, maybe they'll add gtkmm-utils later... Meanwhile, you must download and compile it yourself.

Now, about all my python problems are gone. I had reported dificulty with the zipped version of the source. But since I downloaded the code with bzr and ran ./devconfigure, everything worked alright.