Main pane is a transparent background.

Asked by thesun on 2019-11-19

I just installed RedNotebook via the PPA. Version 2.14. I am on Ubuntu 18.04LTS. When I open the program, the sidebar displays but the main pane is a frozen snapshot of whatever window was behind it. I fixed this in a different program (Bluefish) by adjusting the background and font to be white rather than its apparent default, which was transparent. Is there any way to do that here?

I am able to type, so it's not frozen per se, but it's unusable as whatever garbage was behind is still visible instead of it being on a white "fresh" page.

I have opened RedNotebook both via the toolbar and in a shell and both exhibit this same behavior. Is this a setting on my side I can control somehow? Any help would be great. Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Solved by:
thesun
Solved:
2019-11-19
Last query:
2019-11-19
Last reply:
2019-11-19
Jendrik Seipp (jendrikseipp) said : #1

That sounds like your GTK installation is messed up. I'd look for a solution to this problem before looking at hacks to fix it.

There's no way to set the background from within RedNotebook.

thesun (goemon) said : #2

Okay, thank you. I'll try to find a solution that way.

thesun (goemon) said : #3

I am guessing this is another clue indicating it's not a RedNotebook issue, but still very frustrating: it seems that it works as expected when I begin the program from a shell in my VNC session. Yet when I'm starting (with or without a shell) in my local session, the transparency issue happens.

Does anyone know which forum would be best to post to get help with this? Again, thank you for your help.

thesun (goemon) said : #4

Grrrr. Spoke too soon. The issue still happens, only with a white and not transparent background when I run in VNC.