Querying DVD-ROM Drive on Start-Up

Asked by Zaphod Beeblebrox on 2019-03-24

Since version 2.9.0, every time I start RedNotebook it queries my DVD-ROM drive (F:) and comes back with a "No disc in Drive F:" error, forcing me to either click Cancel about 10 times, or insert a disc in the drive.

This is new behavior that I've never experienced before and can't track down the cause of it. I've tried taking all the files out of the /data folder and restarting the app, thinking that perhaps one of the links inside one of my entries was pointing to a file on an F: drive, but it still queries the drive on start-up.

I looked through the settings to see if there was a startup folder listed there, but no...

The properties for the shortcut are:

Target: "D:\Program Files (x86)\RedNotebook\rednotebook.exe"

Start in: "D:\Program Files (x86)\RedNotebook"

Running Windows 7 with SP1

Just rolled back to version 2.8.0 and everything is working normal again. Tried it with and without my data files.

Any help appreciated! :)

Question information

Language:
English Edit question
Status:
Solved
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Solved by:
Zaphod Beeblebrox
Solved:
2019-03-24
Last query:
2019-03-24
Last reply:
2019-03-24
Jendrik Seipp (jendrikseipp) said : #1

That must be one of the strangest RedNotebook bugs I've heard, yet :-)
Unfortunately, I have no idea where this stems from. Is there anything
in the logfile under C:\Users\<username>\.rednotebook ?

There were no errors in the log file, so I reinstalled version 2.9.1 and ran it twice to generate a new log file.
Still no errors that i can see, also no mention of a drive F: in it...

Here is the log:

2019-03-24 18:02:34,477 INFO Writing log to file "C:\Users\Charles\.rednotebook\rednotebook.log"
2019-03-24 18:02:34,477 INFO System encoding: utf-8
2019-03-24 18:02:34,478 INFO Language code: en_US
2019-03-24 18:02:34,762 INFO Running in portable mode: False
2019-03-24 18:02:34,762 INFO First Start: False
2019-03-24 18:02:34,762 INFO RedNotebook version: 2.9.1
2019-03-24 18:02:34,762 INFO System info: machine: AMD64, platform: Windows-7-6.1.7601-SP1, processor: AMD64 Family 21 Model 2 Stepping 0, AuthenticAMD, python_version: 3.6.8, release: 7, system: Windows, GTK: (3, 22, 30), Glib: (2, 58, 1), PyGObject: (3, 28, 3), YAML: 3.13
2019-03-24 18:02:35,690 DEBUG Default font: Segoe UI 9
2019-03-24 18:02:35,691 DEBUG Default size: 9.0
2019-03-24 18:02:36,049 DEBUG Tray icon visible: False
2019-03-24 18:02:36,051 INFO Opening journal at 'C:\\Users\\Charles\\.rednotebook\\data'

(136 more data files loaded without errors)...

2019-03-24 18:02:36,051 DEBUG Starting to load files in dir "C:\Users\Charles\.rednotebook\data"
2019-03-24 18:02:36,052 DEBUG Loading file "C:\Users\Charles\.rednotebook\data\1980-01.txt"
2019-03-24 18:02:36,226 DEBUG Finished loading files in dir "C:\Users\Charles\.rednotebook\data"
2019-03-24 18:02:36,333 INFO Connected Signals: [<Signals.SIGINT: 2>, <Signals.SIGABRT: 22>, <Signals.SIGTERM: 15>]
2019-03-24 18:02:36,333 DEBUG Start took 1.571089744567871 seconds
2019-03-24 18:02:36,333 DEBUG Trying to enter the gtk main loop
2019-03-24 18:02:36,428 INFO Last backup was made 11 days ago
2019-03-24 18:03:33,506 DEBUG Main frame destroyed
2019-03-24 18:03:33,507 INFO Nothing to save
2019-03-24 18:03:33,507 INFO Goodbye!

Jendrik Seipp (jendrikseipp) said : #3

Sorry, nothing much we can there. Maybe this gets fixed when the
underlying libraries and tools are updated.

I figured you'd say that :-P

I'll just keep trying each new version to see if the problem goes away. If not, I keep the last three or four versions in a folder, for just such an event as this.

Thank You, Jendrik :)