Windows 10 update 1809 start up error

Asked by rgeling on 2018-10-04

After upgrading my Windows 10 PC to version 1809 (October 2018 update) Rednotebook won't start and displays the error "Failed to execute script journal". There are no messages in the log file since the Windows update
Is this a known error with this Windows Update? And can you fix it?

Question information

Language:
English Edit question
Status:
Answered
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-04
Last reply:
2018-11-28
Jendrik Seipp (jendrikseipp) said : #1

Are you using the latest RedNotebook version? Can you try and run the
rednotebook.exe from the commandline and paste the log here?
C:\users\<username>\.rednotebook\rednotebook.log is empty?

Urs Joss (urs.joss) said : #2

I have the same situation @work where I'm forced to use windows. 2.7 running on windows 10 prior to the windows update was working perfectly.

After the windows upgrade, I have tried with 2.7, 2.7.1 and just now with 2.8. All same results.

I started the tool from command line and did not get any output.

The log (.rednotebook/rednotebook.log) remains empty.

The latest entry in the log file may or may not be related with this issue. It's:

C:\Program Files (x86)\RedNotebook\rednotebook\gui\main_window.py:871: Warning: Source ID 1424 was not found when attempting to remove it

Let me know if I can supply any more info to narrow down this annoying issue with the MS update that prevents us using your really nice tool... ;-)

Thanks

Jendrik Seipp (jendrikseipp) said : #3

Maybe this is issue will be fixed by the improved Windows 10 1809 update (https://www.zdnet.com/article/microsoft-resumes-rollout-of-windows-10-version-1809-promises-quality-changes/)? Do you have the old or the new version of this upgrade?

Urs Joss (urs.joss) said : #4

Its the current update:

Feature update to Windows 10, version 1809
Successfully installed on ‎14/‎11/‎2018

Jendrik Seipp (jendrikseipp) said : #5

Hmm, this is very hard to debug without any logs etc.

Urs Joss (urs.joss) said : #6

Fully agree. I just found out I can use strace also on windows - here's the output:

--- Process 8324 created
--- Process 8324 loaded C:\Windows\System32\ntdll.dll at 00007ffcbf380000
--- Process 8324 loaded C:\Windows\SysWOW64\ntdll.dll at 0000000076e80000
--- Process 8324 loaded C:\Windows\System32\wow64.dll at 00007ffcbf2f0000
--- Process 8324 loaded C:\Windows\System32\wow64win.dll at 00007ffcbd590000
--- Process 8324 loaded C:\Windows\System32\wow64cpu.dll at 0000000076e70000
--- Process 8324 loaded C:\Windows\SysWOW64\kernel32.dll at 0000000074c70000
--- Process 8324 loaded C:\Windows\SysWOW64\KernelBase.dll at 0000000074a10000
--- Process 8324 loaded C:\Windows\SysWOW64\user32.dll at 00000000755d0000
--- Process 8324 loaded C:\Windows\SysWOW64\win32u.dll at 0000000076de0000
--- Process 8324 thread 7476 created
--- Process 8324 loaded C:\Windows\SysWOW64\gdi32.dll at 0000000075c40000
--- Process 8324 loaded C:\Windows\SysWOW64\gdi32full.dll at 0000000076980000
--- Process 8324 loaded C:\Windows\SysWOW64\msvcp_win.dll at 0000000075a90000
--- Process 8324 loaded C:\Windows\SysWOW64\ucrtbase.dll at 00000000764b0000
--- Process 8324 thread 10728 created
--- Process 8324 thread 3652 created
--- Process 8324 loaded C:\Windows\SysWOW64\ws2_32.dll at 00000000763f0000
--- Process 8324 loaded C:\Windows\SysWOW64\rpcrt4.dll at 0000000076860000
--- Process 8324 loaded C:\Windows\SysWOW64\sspicli.dll at 00000000744f0000
--- Process 8324 loaded C:\Windows\SysWOW64\cryptbase.dll at 00000000744e0000
--- Process 8324 loaded C:\Windows\SysWOW64\bcryptprimitives.dll at 0000000076e00000
--- Process 8324 loaded C:\Windows\SysWOW64\sechost.dll at 00000000759b0000
--- Process 8324, exception 4000001f at 0000000076f2f0b6
--- Process 8324 loaded C:\Windows\SysWOW64\imm32.dll at 0000000076b40000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\python34.dll at 000000001da70000
--- Process 8324 loaded C:\Windows\SysWOW64\advapi32.dll at 0000000075770000
--- Process 8324 loaded C:\Windows\SysWOW64\msvcrt.dll at 0000000076c00000
--- Process 8324 loaded C:\Windows\SysWOW64\shell32.dll at 0000000075c70000
--- Process 8324 loaded C:\Windows\SysWOW64\cfgmgr32.dll at 0000000076470000
--- Process 8324 loaded C:\Windows\SysWOW64\SHCore.dll at 0000000074960000
--- Process 8324 loaded C:\Windows\SysWOW64\combase.dll at 00000000765e0000
--- Process 8324 loaded C:\Windows\SysWOW64\windows.storage.dll at 0000000074d50000
--- Process 8324 loaded C:\Windows\SysWOW64\profapi.dll at 0000000076dc0000
--- Process 8324 loaded C:\Windows\SysWOW64\powrprof.dll at 0000000076920000
--- Process 8324 loaded C:\Windows\SysWOW64\shlwapi.dll at 0000000076af0000
--- Process 8324 loaded C:\Windows\SysWOW64\kernel.appcore.dll at 0000000076460000
--- Process 8324 loaded C:\Windows\SysWOW64\cryptsp.dll at 0000000075370000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\MSVCR100.dll at 0000000078390000
--- Process 8324 loaded C:\Windows\SysWOW64\rsaenh.dll at 0000000070080000
--- Process 8324 loaded C:\Windows\SysWOW64\bcrypt.dll at 00000000749f0000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\_ctypes.pyd at 000000001c470000
--- Process 8324 loaded C:\Windows\SysWOW64\ole32.dll at 0000000075b10000
--- Process 8324 loaded C:\Windows\SysWOW64\oleaut32.dll at 0000000076d20000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\_bz2.pyd at 000000001c550000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\_lzma.pyd at 000000000fc40000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\pyexpat.pyd at 000000000f530000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\_hashlib.pyd at 000000000ff30000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\_socket.pyd at 000000001de30000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\gi._gi.pyd at 0000000062600000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libglib-2.0-0.dll at 00000000687c0000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libgirepository-1.0-1.dll at 00000000660c0000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libgobject-2.0-0.dll at 0000000063c40000
--- Process 8324 loaded C:\Adding c:\Program Files (x86)\RedNotebook to sys.path
Program Files (x86)\RedNotebook\libffi-6.dll at 000000006b940000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libintl-8.dll at 0000000061ec0000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libgio-2.0-0.dll at 000000006d780000
--- Process 8324 loaded C:\Windows\SysWOW64\winmm.dll at 0000000068e00000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libgmodule-2.0-0.dll at 000000006dd00000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libwinpthread-1.dll at 0000000064b40000
--- Process 8324 loaded C:\Program Files (x86)\RedNotebook\libzzz.dll at 000000006b2c0000
--- Process 8324 loaded C:\Windows\SysWOW64\IPHLPAPI.DLL at 00000000744a0000
--- Process 8324 loaded C:\Windows\SysWOW64\dnsapi.dll at 0000000068c20000
--- Process 8324 loaded C:\Windows\SysWOW64\winmmbase.dll at 0000000068dd0000
--- Process 8324 loaded C:\Windows\SysWOW64\winmmbase.dll at 00000000034c0000
--- Process 8324 loaded C:\Windows\SysWOW64\winmmbase.dll at 0000000003490000
--- Process 8324 loaded C:\Windows\SysWOW64\nsi.dll at 0000000076450000
--- Process 8324 unloaded DLL at 00000000034c0000
--- Process 8324 unloaded DLL at 0000000003490000
--- Process 8324 loaded C:\Windows\SysWOW64\uxtheme.dll at 0000000073e60000
--- Process 8324 loaded C:\Windows\SysWOW64\msctf.dll at 0000000075490000
--- Process 8324 loaded C:\Windows\SysWOW64\dwmapi.dll at 0000000074050000
--- Process 8324 loaded C:\Windows\SysWOW64\crypt32.dll at 0000000076250000
--- Process 8324 loaded C:\Windows\SysWOW64\msasn1.dll at 0000000075c10000
--- Process 8324 loaded C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.17763.134_none_4d606e111b9d4362\comctl32.dll at 000000006b9f0000
--- Process 8324 loaded C:\Windows\SysWOW64\TextInputFramework.dll at 0000000067e90000
--- Process 8324 loaded C:\Windows\SysWOW64\CoreUIComponents.dll at 0000000067c20000
--- Process 8324 loaded C:\Windows\SysWOW64\CoreMessaging.dll at 0000000067b90000
--- Process 8324 loaded C:\Windows\SysWOW64\ntmarta.dll at 0000000074390000
--- Process 8324 loaded C:\Windows\SysWOW64\WinTypes.dll at 00000000681e0000
--- Process 8324 thread 3652 exited with status 0xffffffff
--- Process 8324 thread 7476 exited with status 0xffffffff
--- Process 8324 thread 10728 exited with status 0xffffffff
--- Process 8324 exited with status 0xffffffff

In addition, is there any way I can change the log level? Any command line flags or configuration options in configuration.cfg?

Also - just to be sure - I renamed my .rednotebook folder to make sure it's not something in my data or configuraiton. To no avail.

Jendrik Seipp (jendrikseipp) said : #7

Thanks! Unfortunately, I dont see any actionable stuff in the log and
there's no option for letting RedNotebook be more verbose. Maybe it's
something to with Python 3.4. I'll try to create a version of the
installer with a newer Python version, but that'll take some time.

Urs Joss (urs.joss) said : #8

Thanks Jendrik

Urs Joss (urs.joss) said : #9

Jendrik,

I just wanted to cross link: The following comment from 2017 had the same error message which you solved in 2.0 beta 2.

https://github.com/jendrikseipp/rednotebook/issues/328#issuecomment-324484002

This may be a coincidence and may not be related at all, but just for the reference.

Thanks and cheers
Urs

Jendrik Seipp (jendrikseipp) said : #10

I updated the underlying GTK stack and built a new executable for Windows. The result is not quite finished, but I'm interested in whether it solves your issue. Also, it should print more error logs. Could you please download the tarball from https://ci.appveyor.com/api/buildjobs/cndx9eg6894m15ma/artifacts/rednotebook.tar.gz, extract it (with 7zip) and start the rednotebook.exe program?

Jendrik Seipp (jendrikseipp) said : #11

Regarding the comment from 2017: I think there can be many errors leading to the "Failed to execute script journal" message, unfortunately.

Urs Joss (urs.joss) said : #12

Thanks a lot for taking care of this, Jendrik.

I downloaded and extracted the tarball. However, when I start rednotebook.exe, I always received the following message:

"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."

I tried assigning execute rights to the folder (or even all rights), also moving the folder into different places - but to no avail:

- replacing the installation directory from the official release (C:\Program Files\Rednotebook)
- putting the entire folder somewhere into my users folders (within .rednotebook, within AppData\Local)

I'm still struggling a bit with having to work with Windows at my new job after nearly 20 years of Linux only, so maybe you can provide a hint how to get this version execute properly.

Jendrik Seipp (jendrikseipp) said : #13

Hmm, strange. I'm no Windows expert either, sorry. Can you try
installing this installer
(https://ci.appveyor.com/api/buildjobs/cndx9eg6894m15ma/artifacts/rednotebook-2.9b.exe)?
It contains the same stuff as the tarball.

Urs Joss (urs.joss) said : #14

Installation worked, but running still does not, unfortunately.

The current message (after trying to fix permissions and also installing to "C:\Apps" instead of "C:\Program Files (X86)" to make sure we don't have some space in path issue) is:

Windows cannot access the specified device, path, or file. You may not have the appropriate permissinos to access the item.

It tried to run it as local administrator too - unsuccessfully as well.

Urs Joss (urs.joss) said : #16

I have not yet had time to investigate the issue. But thanks for the primer with those links.

I will try it out this afternoon.

Urs Joss (urs.joss) said : #17

Jendrik, it was the antivirus indeed.

Configuring the installation root dir of RedNotebook in the exclusion list allows Rednotebook to start successfully.

I tried to install 2.8 once more to see if that runs, but with 2.8 I still have the original issue.

So the changes you included in 2.9b solved the original issue that suddenly popped up with that windows update and taming the antivirus did the rest.

Thanks and I'm looking forward to 2.9 final :-)

P.s. not related but since we're chatting: The preview does not work for me in 2.9b. It just disables the panel but does not open either a browser window as before nor anything else. Toggling back to the edit view brings back the markup.

Jendrik Seipp (jendrikseipp) said : #18

Thanks for reporting back! I'll look into the preview issue.

Urs Joss (urs.joss) said : #19

Jendrik, this now works perfectly with 2.9. Thanks for your efforts.

Can you help with this problem?

Provide an answer of your own, or ask rgeling for more information if necessary.

To post a message you must log in.