I seem to have lost all my data - help!!!!

Asked by Charles B on 2018-09-19

Today Rednotebook (1.13 running on Windows 10) wouldn't start. You could see it flash on the screen for a split second.

I do a bit of troubleshooting and find the data files in the user\.rednotebook folder. The one that was saved last night appears to be empty. The .txt file is called 2018-9 (so the current month) and has 30kb. Opening the file shows a blank screen, but doing a Ctrl A highlights the blank document (so there is something there).

I copied that file to another folder.

I opened the rednotebook.txt file and noticed an entry that said something to the effect of "invalid character in 2018-9 in first position".

So, thinking "I've got this", I deleted the first (invisible) character of the original 2018-9 file (the one in the .rednotebook folder) and rednotebook started normally, but with no data.

Of course, now that the system restated, the rednotebook.txt file overwrote the error message.

Putting the original 2018-9 file back results in the same original problem - rednotebook just flashes on screen

The data is vital as it includes a month worth of meeting notes that can't be recreated.

HELP.

Thanks

Charles

Question information

Language:
English Edit question
Status:
Solved
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Solved by:
Jendrik Seipp
Solved:
2018-09-20
Last query:
2018-09-20
Last reply:
2018-09-20
Jendrik Seipp (jendrikseipp) said : #1

It seems the file got corrupted. This probably leads to your editor
showing only blank characters. I think your best bet is to use an editor
in which you can force an encoding and load the corrupted file using the
UTF-8 encoding. You might then be able to fix the corrupted file by
making sure it is in valid YAML format, but just copying your text into
RedNotebook or somewhere else might be easier than fixing the format.

Charles B (charlesbe) said : #2

Thanks so much for speedy help. You guys are great.

While I'm not a techie I think I can follow instructions pretty well.

In order to recreate the error, I put the original 2018-09.txt file back into the ,renotebook folder. It came up with the same error in the rednotebook.txt file as follows ERROR Error in file C:\users\eb\.rednotebook\data\2018-9.txt:
unacceptable character #x0000: special characters not allowed in C:\users\eb\.rednotebook\data\2018-9.txt", position 0

This is run on a computer that is not connected to the internet so I can't post the entire file but it all looks normal until it tries to load the 2018-9 file (it seems to load the 2018-8 file fine - which is when I started this.

I tried to copy the "seemingly blank" content from the original 2018-9 file into redbook once I got it started by moving that file, but that just shows blanks too.

Any thoughts on an editor I can use on Windows that might recover the data? At this point any formatting (or for that matter dates) aren't important.

Thanks again, Charles

Jendrik Seipp (jendrikseipp) said : #3

I recommend using https://notepad-plus-plus.org/ to open the file with
UTF-8 encoding.

Charles B (charlesbe) said : #4

You guys really are good but opening the file in notepad ++ gives me a page of repeating "NUL". Any thoughts?

Best Jendrik Seipp (jendrikseipp) said : #5

Maybe I can recover something if you send me the file. I sent you a private message with my email address.

Charles B (charlesbe) said : #6

That's terrific. Thanks. This is an extremely important project I was working on.

Charles B (charlesbe) said : #7

Thanks Jendrik Seipp, that solved my question.