How can I disable the dreaded PREVIEW mode

Asked by Robert Reather on 2016-09-27

How can I disable PREVIEW?

I have used rednotebook throughout the day for several years. With the update to 1.10 in the latest version of Mint, It is a major shock to find that:

1) rednotebook defaults back to preview mode each time I go to a different date
2) I can't add new text without clicking on the mode button first
3) Text does not appear as I typed it in - unless I click on the mode button

I love rednotebook but HATE preview mode. Is there a way to disable it?

Question information

Language:
English Edit question
Status:
Solved
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Reather
Solved:
2016-09-28
Last query:
2016-09-28
Last reply:
2016-09-28
Robert Reather (rumblings) said : #1

I use Rednotebook as a quick and easy way to store and retrieve information typed or pasted in - and as a diary, and have shortcuts to 9 other rednotebook folders on my desktop for storing notes and info etc pertaining to various activities such as cheese making, poultry, bible notes etc. This has been incredibly useful over past few years, not least due to the fantastic and amazingly useful search facility.

For me, rednotebook is really crippled. I don't want text to appear differently next time I go to it. If I put in a new line, I don't want that to be wiped out. I want rednotebook to be QUICK and EASY - as it has been up. Having to click on the mode button each time I go to a different entry adds a lot of unnecessary clicks and is extremely frustrating.

Sadly I also find the new (to me - ie 1.10.1) version of rednotebook laggy rather than crisp and fast like earlier versions.

I have tried to go back to an earlier version but dependencies are different and I didn't succeed and for the benefit of the whole world and every normal user, I hope to pass on my user experience to the developer/developers who have done such a great job in the past.

Jendrik Seipp (jendrikseipp) said : #2

In the preferences you will find a setting "Automatically switch between
edit and preview mode". If not, consider updating to a newer version.

Could you be more specific about what has slowed down in RedNotebook?

Robert Reather (rumblings) said : #3

I did have the setting for
"switch between edit and preview mode automatically"
ticked -
and thought it wasn't doing anything, however being a single-click person, I hadn't tried double clicking and that does the trick - ie each page will switch to edit mode if I double click in the text. ( I had previously single-clicked umpteen times to no avail)

I'll try that. My habit is to go to a page and click to write. Now I can just double click - not as bad as having to go up to that button or press cntrl P.

It would be fantastic if you put an entry in preferences such as:

"get rid of preview mode forever"
or even just
"disable preview mode completely"

===========

HOWEVER

the edit/preview workaround above still leaves another problem untouched:

When I search I type the text into the search box and see a long list of pages with that entry in them. If I click on one of them to bring it up in the main pane, the search text is NOT HIGHLIGHTED unless I switch to edit mode. It is sometimes highlighted on some pages but in most of them it is not (currently none at all) and that seriously affects search efficiency.

===================

I have tried the daily build pp and so have been trying 1.14 for past hour - I notice no difference.

====================

THE DELAY - can I be more specific?
Yes - it is the search. With my main rednotebook, I can type quite a long word in the search bar and then wait for it to appear. With the other (smaller) rednotebooks I use (accessed by using different folders, accessed by editing the path in the relevant rednotebook shortcut on my desktop) there is no delay ie text appears in the search bar as soon as I enter it.
This is probably related to the number of text files there are in this rednotebook folder - 252 txt files - ie 252 months.
If I remove some of these the delay diminishes.

According to the log, it takes 1.87061595917 seconds to open the main rednotebook (compared to 0.796549081802 seconds for a rednotebook with only a few entries) and there is also usually an entry like
2016-09-27 13:15:04,917 DEBUG Add mathjax code: False
for the main rednotebook and not for the others.
(which I realise is very likely nothing to do with the problem)

The longer startup is neither here nor there but the delay in search is new compared with the previous version I was using (possibly 1.8)

Jendrik Seipp (jendrikseipp) said : #4

Thanks for the details.

You can disable the preview mode by *unticking* "switch between edit and
preview mode automatically" and never manually switching to preview mode.

Robert Reather (rumblings) said : #5

That didn't work - at first - kept switching into preview mode and the box in preferences would become ticked again, however . . .

renotebook was trying to write to the cfg file on shutdown and couldn't as I had the file set to read only. Changing it back to the default of read/write has solved the edit/preview problem. I don't know why this problem should have suddenly appeared (after over 4 years of having it set to read only). It may have been trying to write something about a backup. The mysterious (to me) line about "Add mathjax code: False" is no longer appearing in the log now.

Changing permissions of the cfg file was my responsibility so the problem was my fault and I apologise for wasting your time and for the adjective used in the subject. Yes I know, that is the first thing I should have tried but . . .

Thanks for making such a great bit of software. I find it extremely useful - and intuitive and it is a relief to have it back to normal again.

Why did I have the cfg file set to read only? So I could change the path for the data files to an encrypted folder and not have it reset each time I opened rednotebook and forgot to mount the encrypted folder. A better solution though - it seems - is making a shortcut to open rednotebook and then editing the path in properties, and that also allows multiple instances or rednotebook/sets of data files.

Calvin Taylor (calvintaylor70) said : #6

I just registered to ask the same question. I'd prefer to have everything that is rednotebook without any formatting or preview mode. By forcing formatting on me your batting me over the head, and I don't like it.

Robert Reather (rumblings) said : #7

I've had no further problems with rednotebook since returning the file /home/xxx/.rednotebook/configuration.cfg to its original read/write status. I regard it as one of the top 10 if not top 5 most useful programs I've come across.

I haven't had to look at the dreaded preview mode since - well apart from one moment of madness when I clicked on that hated little triangle just to have another look.

In my case, I was batting myself over the head - it was my own fault. What is the problem in your case? Does it keep defaulting to preview mode? Have you checked that your /home/xxx/.rednotebook/configuration.cfg file has original read/write permissions? (I think that is: you/"owner" have read and write and "group" and "others" are read only)