save location for journal entries

Asked by Tom Braeunig on 2016-05-28

Is there any way to change the location where the journal entries are saved?
I seem to have lost about 4 months worth of entries, and I'm wondering if they were inadvertently saved to another location

Question information

Language:
English Edit question
Status:
Solved
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Solved by:
Tom Braeunig
Solved:
2016-06-04
Last query:
2016-06-04
Last reply:
2016-05-31
Jendrik Seipp (jendrikseipp) said : #1

You can change the journal's location by using "Journal"->"Save As". You
might want to do a system-wide search of "2016-04.txt" or similar to
find your entries.

Tom Braeunig (tfbraeunig) said : #2

I was able to recover all of my missing files. They were in a backup (EASEUs) that I had run on May 13. I found them in a rednotebook file on the DESKTOP on that backup.
I can't figure out how they got onto the desktop, but it was after I cleaned up my desktop on my current drive that I discovered that they were missing.
A system-wide search of both my C drive and my external backup drive didn't find the missing files. I had to manually go to the the backup file on my external drive, open the desktop and there they were.
One thing that I have been doing for a while, which may have caused this, is that I've been doing a "Journal/Save" every time I complete a daily entry. Possibly doing that save function puts the yyyy-mm .txt files on the desktop rather than in the data folder of rednotebook.
One other thing that happens periodically is that, when I open RedNotebook, I'll get a popup with the message "There appears to be another instance of Rednotebook running" Maybe I was using 2 different instances of rednotebook, and they were storing the files in different locations.
Anyway the problem is solved, and I got all my files back. Thanks for your help.

Calvin Taylor (calvintaylor70) said : #3

perhaps you could insert meaningful text in the default file name to make searching easier. eg red-notebook-2016-014.txt

Calvin Taylor (calvintaylor70) said : #4

find . -name "201?-??.txt" worked fine