data file text format not the same on different days

Asked by Randal J. Hoffner on 2013-03-16

I've been trying out RN for the last week or so and I really like the program and I appreciate the work that you obviously put into it. I like the clean and simple interface and that the data file is saved to a simple text file.

Because I'm very concerned about loosing any data, I've been checking the main data file quite often prior to archiving it. In reviewing this data file I've run into a problem that I'm hoping you can explain and help me to correct.

On eight of the ten days that I have entered data, the text for those days is very easy to read in a normal text editor. I use Editpad to review my file and when I review these particular days they display in Editpad almost as well as they do in RN. What I mean by this is that the line breaks and paragraph spacing is all correct and apart from a few markup characters like ** for the bold type, the text could easily be copied and pasted into any other word processor with very little editing.

But on two different days the text file is formatted totally different. On these days there are no paragraph or line breaks, just one solid block of text with "\n" and "\" characters inserted throughout this one solid block of text.

When these different days are displayed in RN they all display fine, and you would never know how different they display in a text editor. I really like being able copy the text directly from my data file without having to deal with all of the "\n" and "\" characters.

Can you tell me what I'm doing that causes this to happen and also if there is a way to get the text back to what I would call a "normal" format that is readable in a text editor.

I'm using XP SP3 and the 1.7.1 portable version of RN.

Thanks again for such a great program.

Question information

Language:
English Edit question
Status:
Answered
For:
RedNotebook Edit question
Assignee:
No assignee Edit question
Last query:
2013-03-18
Last reply:
2017-03-15
Jendrik Seipp (jendrikseipp) said : #1

Hmm, good question, I had a look at the files and the sourcecode, but
could not figure out how the underlying pyyaml library chooses this
setting. If you find a parameter with which I can change it, I'll be
happy to apply it.

Randal J. Hoffner (rhoffner) said : #2

Hi Jendrik,

I'm not that knowledgeable on what's going on, I only know the end result that I see in my text editor. It happened again last night.

The only clue that I have to offer is that it seems to occur when I go back and edit things. I had a couple of pages of text typed in yesterday morning and I backed that file up. Later in the evening I made some additions and corrections for the day. When I then compared the two text files, the original file that was done in the morning was what I would call "normal" and the file that had the additions and corrections in it was now one solid text block with the "\n" and "\" characters inserted in place of the line breaks or paragraphs. Because I don't really understand the programming, my only guess is that I've been accidentally hitting a keyboard shortcut or something.

I begin each day of my journal with a custom date (%A, %B %d, %Y) in bold type, but nothing else special. If you looked at my data file in a text editor you will see that days1,2,4,5,7,8, & 9 have normal page breaks and don't contain any "\n" or "\" characters. Day 3,6, & 10 are all one solid block of text with the "\n" and "\" characters inserted throughout.

If you come up with anything that I can do differently I would be glad to try it.

Thanks

Jendrik Seipp (jendrikseipp) said : #3

Sorry, I don't know what else to try. The docs are not very sparse on
that matter.

Randal J. Hoffner (rhoffner) said : #4

Jendrik,

I realize that this is an old question but I just found the reason that RN does "block formatting" on occasion and I wanted to pass it on.

Whenever a paragraph has an extra "blank" space at the end, it will cause RN to "block" format the data for that entire day into one large paragraph when the progarm is closed.

If RN is re-opended and the extra "blank" space removed, RN will then re-save that days data in the "normal" format.

There may be other things that cause the block formatting as well, but so far this has reloved my problems.

Edward Chmiel (edthec) said : #5

I too have this problem, and there seems to be no work around on this for me. I just do not understand why, if go back, the format is lost and you have to go into edit to see the text the way you entered it. BTW, it's just a simple matter of carriage return line feed, not working. Its extremely frustrating. Can there be an option to allow on to always have Edit on?

Jendrik Seipp (jendrikseipp) said : #6

The issue described in the last message (#5) is probably just due to the fact that carriage returns are ignored (as in most markup languages). You will need to enter \\ or use an empty line.

Can you help with this problem?

Provide an answer of your own, or ask Randal J. Hoffner for more information if necessary.

To post a message you must log in.