How do I blacklist applications?

Asked by Stefano Coronado on 2014-01-12

Basically I have music playing from Rhythmbox and all of the songs that change are getting shown as it looks like a message. I don't want every song to show, it's too cluttured.

Question information

English Edit question
recent-notifications Edit question
No assignee Edit question
Solved by:
Jason Conti
Last query:
Last reply:
Jason Conti (jconti) said : #1

The indicator does not have that functionality. It would be easy enough to add if somebody wanted to submit a branch.

Best Jason Conti (jconti) said : #2

I guess somebody is me, because I added support this morning to the saucy package. It's currently building in the ppa and should be available shortly.

The blacklist is an array of strings in gsettings, so if you wanted to blacklist an app name 'cake' it would look something like:

gsettings set net.launchpad.indicator.notifications blacklist "['cake']"

Or of course you could edit the settings graphically with dconf-editor. App names are case-sensitive for the moment. It will be listed in the notification: "from appname"

Please be sure to file any bugs you find.

Jason Conti (jconti) said : #3

Oh, also for the moment, if you add an app name while the indicator is running, it will only discard future notifications, it won't go through and remove ones you already received.

Stefano Coronado (stefanoume) said : #4

Excellent, Thanks for being right on it. I will file a bug report if I see any problems.

dimetry (info999) said : #5

Useful for me indicator, but sometimes it is over-spammed by Volume from indicator-sound.

I've tried blacklist
but with no success.

How can I make correct blacklist to exclude notifications from sound?

dimetry (info999) said : #6

My fail.
I have to restart recent-notifications application to apply.

blacklist ['indicator-sound'] - work as needed


Stefano Coronado (stefanoume) said : #7

Thanks Jason Conti, that solved my question.