bug when directory names contain accents

Asked by Laurent Lyaudet on 2012-08-25

I installed latest rabbitVCS on ubuntu 12.04.
RabbitVCS seems to work fine except for directories with accent.
When I did the first checkout on my svn repository, the directory remained empty.
I thought it had done nothing but the directory had the green icone saying all was ok.
I'll try to upload a screen capture if possible.
It took me a while to figure out that the checkout had been done but since some directories on the path had accents it had created a new path with encoded accent instead.
Example if you do the checkout on ~/Données/Svn, it will create ~/Donn%C3%A9es/Svn and put the files there.
I hope you can correct this bug.
Thanks in advance, best regards,
   Laurent Lyaudet

2012/09/01 update : Now rabbitVCS functions only on directory without accents. All rabbitVCS options in the contextual menu disappear if you click right on a directory with accents.

Question information

Language:
English Edit question
Status:
Expired
For:
RabbitVCS Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-25
Last reply:
2012-09-10
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

dada (daouzli) said : #2

Hi, I encoutered the same problem. Is there any way to fix it?

dada (daouzli) said : #3

This problem is covered by an issue that was first fixed in the release 0.15.1 but applying only for spaces use.
A patch for accents is proposed until it will be incorporated to a new release.
The concerned issue is Issue 628 : http://code.google.com/p/rabbitvcs/issues/detail?id=628