'quickly share' cannot sign files

Asked by Sean Welton on 2010-02-01

Every time I try to run 'quickly share' I get an error that it can't sign the .dsc or .changes file. It complains that I don't have a secret key available, when I definitely do. It almost looks like its trying to use my ssh key and not my pgp key... I'm basically trying to upload an app I developed to my PPA on launchpad, but I can't get it to work. Am I doing something wrong here? I pasted a relevant bit of the output below. I've already got my key in Launchpad, so that shouldn't be the problem..

gpg: skipped "Sean Welton <sean@procyon>": secret key not available
gpg: [stdin]: clearsign failed: secret key not available

dpkg-genchanges -S >../eggtimer_0.1_source.changes
dpkg-genchanges: including full source code in upload
dpkg-buildpackage: source only upload: Debian-native package
dpkg-buildpackage: warning: Failed to sign .dsc and .changes file
ERROR: an error occurred during source package creation
ERROR: share command failed
Aborting

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Quickly Edit question
Assignee:
No assignee Edit question
Solved by:
Sean Welton
Solved:
2010-02-02
Last query:
2010-02-02
Last reply:
2010-02-02
Didier Roche (didrocks) said : #1

Thanks for using Quickly,

Concerning your question,, there is no way it's trying to sign with your GPG key.
I guess the issue is coming from there: "using Sean Welton <sean@procyon>". Is that the name you have on your GPG key? (letter by letter).

If not, I guess you have to export DEBEMAIL="First_name Last_Name <email address hidden>" exactly the same than on your GPG key.

You can hop on #quickly if you need further help.

manatlan (manatlan) said : #2

same trouble here ...

$ gpg --list-secret-keys
/home/manatlan/.gnupg/secring.gpg
---------------------------------
sec 1024D/XXXXXXXX 2006-11-09
uid manatlan <email address hidden>

after an export like that
$ export DEBEMAIL="manatlan <email address hidden>"

"quickly share" ends with :
gpg: « manatlan <manatlan@manatlan-desktop> » a été ignoré: la clé secrète n'est pas disponible
gpg: [stdin]: clearsign failed: la clé secrète n'est pas disponible

Didier Roche (didrocks) said : #3

Try to export your DEBSIGN_KEY="XXXXXXXX", remove debian/ directory and try to share again.

manatlan (manatlan) said : #4

Ok ... it works for me now ...

debian folder removed !

and "share" runned like this :
DEBSIGN_KEYID="XXXXXXXX" quickly share

manatlan (manatlan) said : #5

10 hours after, my ppa is not up to date ...
(and I had comitted "3 shares")
is it normal ?

note that : "quickly share" ask me always to enter my passphrase (for my gpg key) two times ! It always doesn't work the first time ! strange behaviour because it always say that it can't access to a seahorse things (uri) ... and the second time it works !? perhaps it's the trouble ... btw, "quickly share" says me that it was uploaded and asks me to wait half an hour to see changes in my ppa

Didier Roche (didrocks) said : #6

Normally, you should get an email from LP in your preferred adress email telling either your upload is accepted or denied.

Asking you the passphrase twice is totally normally (it's signing first the .dsc and then the .changes file) and it's the everyday life of packagers. So, nothing strange here, appart that gnome-keyring isn't triggered the first time for you (which seems to be a bug, is gnome-keyring started during startup phase?)

So, check your emails.

Sean Welton (spwelton) said : #7

I was able to run 'quickly share' the other day. The fix was to add my name, with no comments, to my PGP key.

Thanks for all your help!!
Sean

I failed to get this working with the export stuff. Instead I opened my gpg key in the key manager for my user and added the name stated in the --verbose output. Then it worked!

Didier Roche (didrocks) said : #9

are you using 0.4? If so, I'm interested in your result as it should be fixed in 0.4 (worked with some volonteers :)) without any export to do.

Can you go into #quickly next week on freenode and ping me?
Thanks a lot.

KillerKiwi (killerkiwi2005) said : #10

got the same error karmic Quickly 0.2.5

Didier Roche (didrocks) said : #11

you should either do what is written above or migrate to Quickly 0.4 on lucid which fix this issue.