How do I change the default editor in quickly edit

Asked by Guillaume Sorbier on 2009-11-05

I have tried to change the default editor via nautilus on a text file:
right click > Properties > Open with > Geany
but when I run again quickly edit I still have gedit in default

Question information

Language:
English Edit question
Status:
Solved
For:
Quickly Edit question
Assignee:
No assignee Edit question
Solved by:
Guillaume Sorbier
Solved:
2009-11-05
Last query:
2009-11-05
Last reply:
2009-11-05
Didier Roche (didrocks) said : #1

Thanks for using Quickly!

Quickly use sensible-editor to achieve that with Debian preferences.
You can either:
export EDITOR=whatevereditoryouwish

(put it in your ~/.bashrc if you want to keep this setting)

or execute:
sensible-editor which will give you some alternatives to choose one.

Do not hesitate to ask for further demands.

thank to you!

and thanks to all who propose this rad

LordPhoenix (lorphoenix) said : #3

I've tried sensible-editor command but I've got choice between ed, nano or vim. Is there a way to add another editor?  (I would like use Geany).

Didier Roche (didrocks) said : #4

@LordPhoenix:
As written previsouly, you can just export EDITOR=geany.
(put it in your ~/.bashrc if you want to keep this setting)

Then you can just run "quickly edit".

Skyler Lehmkuhl (skykooler) said : #5

Is there any way to make only Quickly use Geany and all other applications use e.g. Gedit?

Hi Skyler,

I'm pretty certain that Didier set it up so that you can do this. In the meantime, you can tell the quickly edit command to use geany by running it like this:
$EDITOR=geany quickly edit

HTH

Cheers, Rick

Hah! I was right. There is a environment variable just for this:
$export QUICKLY_EDITOR=geany
then $quickly edit will use geany for the rest of that session. You probably want to use
$quickly edit &
with the "&" to make sure you get the command line back.

You can add QUICKLY_EDITOR to your ~/.bashrc file if you want to keep it this way.

HTH

Cheers, Rick

Skyler Lehmkuhl (skykooler) said : #8

Thank you very much, that was just what I needed!