Attempting to use any launchpad related commands results in "No gpg key set"

Asked by Philip Peitsch on 2009-10-30

Hi!

I've been playing around with quickly, and though all the local stuff works well, everytime I attempt to share or release a package I get the following:
Launchpad connexion is ok
No gpg key set. Take a look at quickly tutorial to learn how to setup one
ERROR: share command failed
Aborting

I have been through all the tutorials and cannot find anything referencing how to set the gpg key. Can anyone give me any pointers or assistance?

On an unrelated note, I'm greatly enjoying how easy quickly makes so many of these things! Thanks for all the work going into this!

Question information

Language:
English Edit question
Status:
Solved
For:
Quickly Edit question
Assignee:
No assignee Edit question
Solved by:
Didier Roche
Solved:
2009-10-30
Last query:
2009-10-30
Last reply:
2009-10-30
Best Didier Roche (didrocks) said : #1

Thanks a lot for you interest and feedbacks in Quickly.

gpg key is compulsory when you want to share or release in Launchpad, hence this check.

You will find all instructions to set up it and upload it to Launchpad on this page: https://launchpad.net/~peitschie /+editpgpkeys

Do not hesitate to ask in case of any issue you might encounter. You can also jump on #quickly on freenode (IRC) where we generally hop in ;)

Our goal in Quickly 0.4 (which will be included in lucid lynx) is to make this task as easy as possible. We are investigating on that way.

Hi Didier,

Thanks for the prompt reply :-). Your links and posts made me realise I was confusing my ssh key for my gpg key! Many thanks for the help... I look forward to continuing to play with quickly.

Thanks Didier Roche, that solved my question.