Why CouchDB 10 and not 9?

Asked by Johan on 2009-10-09

Why is CouchDB 0.10.0a used in the Quickly package and not the stable 9:th version?

I'm trying to get Quickly working on my computer and can't get CouchDB to work. I'm very new to these kind of things so any help is welcome.

I've followed the installation instructions on the Quickly wikipedia site, https://wiki.ubuntu.com/Quickly.

/Johan Andersson, Sweden

****************Techinfo****************
1. "couchdb" gives:
Apache CouchDB 0.10.0a (LogLevel=info) is starting.
{"init terminating in do_boot",{{badmatch,{error,shutdown}},[{couch_server_sup,start_server,1},{erl_eval,do_apply,5},{erl_eval,exprs,5},{init,start_it,1},{init,start_em,1}]}}
init terminating in do_boot ()

2. "dpkg -l|grep couchdb" gives:
ii couchdb 0.10.0~svn818859-0ubuntu1 RESTful document oriented database, system D
ii couchdb-bin 0.10.0~svn818859-0ubuntu1 RESTful document oriented database, programs
ii evolution-couchdb 0.3.0-0ubuntu2 Evolution support for CouchDB databases
ii libcouchdb-glib-1.0-1 0.5.0-0ubuntu1 GLib-based API for CouchDB
ii python-couchdb 0.6-1 library for working with Apache CouchDB

Question information

Language:
English Edit question
Status:
Answered
For:
Quickly Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-09
Last reply:
2009-10-09
Ken VanDine (ken-vandine) said : #1

The requirement isn't directly on couchdb 0.10, but on desktopcouch. desktopcouch has a requirement on 0.10 for many reasons, mostly related to the desire to sync desktopcouch databases.

Are you trying to get ti working on a version earlier than Karmic? If you are on Karmic, you can just install from universe:

$sudo apt-get install quickly

and it will all just work. I'm updating the wiki now, sorry, it got a bit out of date.

Cheers, Rick

Johan (johan-andersson-78) said : #3

Thank you, I re-installed all of it and is going to go through the tuorial to begin with.

CouchDB (command line version at least) still doesn't seem to work but that's perhaps not a problem?
(I notised that you removed the couchdb test in the wiki. But then I haven't really gotten anywhere in the process, learning on the way...)

I'm running Karmic (9.10) on amd64.

/Johan

Johan (johan-andersson-78) said : #4

Works like a charm! :)
Really cool, now I "just" need to learn Python.

/Johan

Hop into #quickly on freenode if you have any Python questions, etc...

Welcome!!

Elliot Murphy (statik) said : #6

On 10/09/2009 12:46 PM, Johan wrote:
> CouchDB (command line version at least) still doesn't seem to work but that's perhaps not a problem?

CouchDB is started automatically when an application tries to use it via
desktopcouch.

The couchdb command is not designed to be run directly by an end user,
the error message you posted is because of the user not having
permissions to access some of the config files.

The best way for an interested hacker to see whether desktopcouch is
running ok is to visit
file:///home/<username>/.local/share/desktop-couch/couchdb.html in your
browser. After a brief message, it will redirect and connect you to the
futon interface for the couchdb instance that is running on a dynamic
port in your user session (this is not a system-wide couchdb instance,
it's specifcally for your user).

Hope this helps.
--
Elliot Murphy | https://launchpad.net/~statik/

Can you help with this problem?

Provide an answer of your own, or ask Johan for more information if necessary.

To post a message you must log in.