'quickly package' problems with Ubuntu Accomplishments project

Asked by Jono Bacon

Recently I have been building the Ubuntu Accomplishments project which is a Quickly project. I am now getting to a point where I want to deliver a package. Unfortunately 'quickly package' does not work.

The code for the project is in https://code.launchpad.net/ubuntu-accomplishments-system (or just use lp:ubuntu-accomplishments-system).

The project involve a backend and a front-end and as such the source files and directory structure has been laid out a little differently to make more logical sense. Inside the 'accomplishments' dir you can see the 'daemon' and 'gui' sub-dirs that reflect the daemon and the GUI client.

When I run 'quickly --verbose package' I get the following errors:

jono@forge2:~/source/ubuntu-accomplishments-system$ quickly --verbose package
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: specified class size for type `PyGtkGenericCellRenderer' is smaller than the parent type's `GtkCellRenderer' class size
  from gtk import _gtk
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_get_qdata: assertion `node != NULL' failed
  from gtk import _gtk
setup.py install_egg_info failed
An error has occurred when creating debian packaging
ERROR: can't create or update ubuntu package
ERROR: package command failed

This looks like it is an issue with distutils.

Can anyone help recommend a solution so I can use 'quickly package' and 'quickly release' with this project?


Question information

English Edit question
Quickly Edit question
No assignee Edit question
Solved by:
Jono Bacon
Last query:
Last reply:
Revision history for this message
Jono Bacon (jonobacon) said :

I talked with didrocks today about this and this seems to be an issue with the backend using Twisted's glibc reactor and PyNotify (which uses GTK2) and the front-end using the GTK3 bindings an GI.

I am breaking this out into two different codebases, so I am marking this problem as solved. Thanks!

Revision history for this message
Szymon Waliczek (majster-pl) said :

Hi Jono!

I run in to the same problem but I having problem with solving it as I don't understand what you mean by
"I am breaking this out into two different codebases" sorry but I new to programming...

If You could explain to me a bit closely what You mean by this I will appreciated.