PHP Fatal error: Uncaught Exception

Asked by Andre Santos on 2018-10-22

quexs 2.2.0
db: MariaDb 10.2.18
PHP: 7.0.32
Limesurvey: 3.15.1

Was working ok, now I have this error everytime I trie to add a sample to a questionaire:

[22-Oct-2018 16:33:29 Europe/****] PHP Fatal error: Uncaught Exception: Request error: CDbCommand falhou ao executar o comando SQL: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 1' at line 1 in /include/JsonRPCClient.php:189
Stack trace:
#0 /functions/functions.limesurvey.php(302): org\jsonrpcphp\JsonRPCClient->__call('delete_particip...', Array)
#1 /admin/assignsample.php(513): lime_get_token_attributes('34')
#2 {main}
  thrown in /include/JsonRPCClient.php on line 189

any ideias?

Question information

Language:
English Edit question
Status:
Solved
For:
queXS Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Zammit
Solved:
2018-10-23
Last query:
2018-10-23
Last reply:
2018-10-22
Best Adam Zammit (adamzammit) said : #1

Looks like the error is coming out of Limesurvey when calling the delete_participant function.

Did you update Limesurvey recently?

Also please confirm that the Limesurvey survey you are referencing has the participants/tokens table activated.

Adam

Andre Santos (andre-ars) said : #2

Thanks for the quick response Adam,

yes, it's on the limesurvey side. I've downgraded limesurvey and it's working again.

At this point there isn't any reported bugs referring the problem on their side.

for now, version 3.15.1 it's a "Do not use".

I can't test all the versions, since i can't find an archive repository of limesurvey.

I'm now using version 3.14.10

Andre Santos (andre-ars) said : #3

Thanks Adam Zammit, that solved my question.

Andre Santos (andre-ars) said : #4

quick update, still not solved on limesurvey version 3.15.3, so, do not upgrade