Timezone incorrect in Operator Panel

Asked by Thomas Graydon-Guy on 2018-09-18

Hi there,

I'm using the latest versions of queXS and LimeSurvey and having trouble setting the timezone.

I've set a default timezone of 'NZ', and also set my queXS account to 'NZ', but when in operator panel I get Victoria/Australia when trying to set an appointment.

I have the 'alternate interface' switched on, but disabling this doesn't help. I've also tried adding a field 'Timezone' to the sample, and checked the quexs database user can read the timezone tables, as has been discussed in another question.

In the quexs database, I can see timezone_template has Time_zone_name set to 'NZ'.

sample_postcode_timezone, sample_prefix_timezone and sample_state_timezone are all empty.

Thanks,
Thomas

Question information

Language:
English Edit question
Status:
Solved
For:
queXS Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Zammit
Solved:
2018-09-18
Last query:
2018-09-18
Last reply:
2018-09-18
Best Adam Zammit (adamzammit) said : #1

Hi Thomas,

Setting appointments is always done in "respondent time" - so my guess is that your sample is in that timezone. Did you import the sample before changing the default timezone to NZ?

After confirming the default timezone is NZ, please try disabling any existing sample files, and re-importing them and trying again.

Adam

Thomas Graydon-Guy (tgrayguy) said : #2

Thanks Adam Zammit, that solved my question.