questionnaire shift issue

Asked by Nicolas Reali on 2016-06-23

Dear all,

I just installed the latest version of queXS (1.14.1), after all settings, create a
questionnaire and put into production, I run into an error when trying to add shifts to it.

When I define the year, week, day and turn on the shift, after pressing the "save changes" buton, nothing happen. The selected shift goes back to the "No" state, but at shift table in quexs database, the shift was created with "start" and "end" value "0000-00-00 00:00:00"

In the other hand, mySQL has the timezone installed, and default time zone defined at queXS

So I'm lost here, I appreciate your help.


Question information

English Edit question
queXS Edit question
No assignee Edit question
Last query:
Last reply:
Adam Zammit (adamzammit) said : #1

Hi Nicolas,

Can you please confirm what version of mysql you are using and what version of PHP on what operating system?

Also please confirm that the database user for queXS is either a superuser or has read access to the mysql timezone table - for example:

GRANT select on mysql.time_zone_transition_type to 'quexs'@'localhost' IDENTIFIED BY 'password' ;
GRANT select on mysql.time_zone_transition to 'quexs'@'localhost' IDENTIFIED BY 'password' ;
GRANT select on mysql.time_zone_leap_second to 'quexs'@'localhost' IDENTIFIED BY 'password' ;
GRANT select on mysql.time_zone to 'quexs'@'localhost' IDENTIFIED BY 'password' ;
GRANT select on mysql.time_zone_name to 'quexs'@'localhost' IDENTIFIED BY 'password' ;


Nicolas Reali (nreali) said : #2

Hi Adam,

It has been a long time since our last contact. It's good to read you again.

The mysql user for quexs is a superuser and has access to the mysql timezone table. Right now I'm testing the new quexs release at a Citrix XenServer virtual machine. The base system is a debian 8.5 (kernel 3.16.7 ), MySQL 5.5.49 and PHP 5.6.22

thanks in advance!


Adam Zammit (adamzammit) said : #3

Hi Nicolas,

I am currently testing this on a similar virtual machine - can you please send through your file (without username/passwords)

Thank you.


Nicolas Reali (nreali) said : #4

Hi Adam,

here I pasted the's content:


 * Configuration file
 * This file is part of queXS
 * queXS is free software; you can redistribute it and/or modify
 * it under the terms of the GNU General Public License as published by
 * the Free Software Foundation; either version 2 of the License, or
 * (at your option) any later version.
 * queXS is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * GNU General Public License for more details.
 * You should have received a copy of the GNU General Public License
 * along with queXS; if not, write to the Free Software
 * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
 * @author Adam Zammit <email address hidden>
 * @copyright Deakin University 2007,2008
 * @package queXS
 * @subpackage configuration
 * @link queXS was writen for DCARF - Deakin Computer Assisted Research Facility
 * @license The GNU General Public License (GPL) Version 2

 * Only some of the configuration directives are here. See the file: config.default.php for them all
 * Make your configuration changes in this file only - they will "overwrite" the default configuration

 * VoIP definitions

 * The Asterisk server conf
define('VOIP_SERVER', '');
define('SUPERVISOR_EXTENSION', "7541");
define('VOIP_ADMIN_USER', 'xxxx');
define('VOIP_ADMIN_PASS', 'xxxx');

 * Whether to automatically pop up a coding window when the respondent hangs up

 * The number of minutes of inactivity to wait before automatically logging out an operator with an open screen
 * False to disable

 * The path to LimeSurvey and queXS from the server root
define('LIME_PATH', 'include/limesurvey/');
define('QUEXS_PATH', '/quexs-1.14.1/');

 * Define how many minutes between each system sort (defaults to 5 as this is a common interval for appointments)

 * Temporary upload directory
define('TEMPORARY_DIRECTORY', "/tmp");

 * Database configuration for queXS
define('DB_USER', 'root');
define('DB_PASS', 'xxxxxxx');
define('DB_HOST', '');
define('DB_NAME', 'quexs');

 * Company Information
if (!defined('COMPANY_NAME')) define ('COMPANY_NAME', 'queXS TEST ');
if (!defined('ADMIN_PANEL_NAME')) define ('ADMIN_PANEL_NAME',' Administration Panel TEST');



Adam Zammit (adamzammit) said : #5

Hi Nicolas,

I can't replicate this error on my copy of Debian 8.5

Can you please confirm that the operator you are logged in as has their own timezone set : Go to Operator management, then edit the current operator and make sure the timezone is set to a valid one and try again.


Can you help with this problem?

Provide an answer of your own, or ask Nicolas Reali for more information if necessary.

To post a message you must log in.