No calls with or without Voip

Asked by Nkosy on 2015-11-05

Hi all

Thank you so much for all the hard work that you have put on this project, i am new on queXS but i manage to make it run without problems .

 I am running quexs-1.13.1 on ubuntu fresh install with asterisk-13 , and i was able to configure all the steps on the documentation without any problems and it can give me everything except the outgoing calls .My aim is to dial out and capture response from the respondents

i tested on windows machines as clients using microSip as sip client and X-lite.

On the firefox web browser its says VOIP ON with Voip enabled on my operator settings and also on queXS, but when i click on CALL/HANGUP it just keep REQUESTING and i can move on to the questionnaire and complete everything but i have to dial manually on my sip clients in order to communicate with the respondent

The time_zone set to operators is Africa/Johannesburg and also on my samples the time_zone seems ok as Africa/Johannesburg.

My AMI on the manager.conf file is configured as in the config.inc.local.php and config.default.php on queXS

And when i monitor the Voip on the administrative interface here is the output it shows

Log id Date Log entry
6279 Thu 05 Nov 01:21PM Reconnected
6278 Thu 05 Nov 01:21PM Disconnected
6277 Thu 05 Nov 01:19PM Reconnected
6276 Thu 05 Nov 01:19PM Disconnected
6275 Thu 05 Nov 01:18PM Registered Extension SIP/4004
6274 Thu 05 Nov 01:18PM Registered Extension SIP/4004
6271 Thu 05 Nov 01:17PM Reconnected

i am not quit sure what did i miss in my configurations , Should i downgrade to the older asterisk ?

my asterisk is working fine i can make external call without queXS

how should i integrate my sip clients on my windows machines with queXS for calls to take place ?

Thank you so much, any responses are greatly appreciated

Question information

Language:
English Edit question
Status:
Solved
For:
queXS Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Zammit
Solved:
2015-11-09
Last query:
2015-11-09
Last reply:
2015-11-09
Adam Zammit (adamzammit) said : #1

Hello,

This can occur due to the ORIGINATE_CONTEXT directive in queXS. By default it is set for 'from-internal' (which is what FreePBX uses) but the default installation of Asterisk typically uses 'default'. Please try this directive in your config.inc.local.php file:

 define('ORIGINATE_CONTEXT','default');

You would then need to configure your SIP clients to auto-answer incoming calls.

Regards,
Adam Zammit

Nkosy (gabuza24) said : #2

Dear Adam

Thank you so much for your early response . it was exactly this line define('ORIGINATE_CONTEXT','default'); why i couldn't make calls . I can see the progress now , my sip client can now respond back to me with the reason why i cannot get hold of the respondent.

I tried it with the freepbx , define('ORIGINATE_CONTEXT','from-internal'); and i get the message from sip client that says calls cannot be completed as dialed please check the number and dial again . i am sorry if this question is more based on freepbx but i can also make calls from my sample with freepbx

tried to change my manager.conf file and change the IP address and i get the following massage from asterisk CLI

[2015-11-06 16:26:24] NOTICE[12649]: manager.c:2629 authenticate: 127.0.0.1 tried to authenticate with nonexistent user 'admin'
[2015-11-06 16:26:24] NOTICE[12649]: manager.c:2666 authenticate: 127.0.0.1 failed to authenticate as 'admin'

when i put the following settings on my manager.conf i get the message that i cannot complete the call as dial, its sound like it is not possible to change the IP address on manager.conf

[general]
enabled = yes
port = 5038
bindaddr = 0.0.0.0
displayconnects=no ;only effects 1.6+

[admin]
secret = amp111
deny=0.0.0.0/0.0.0.0
permit=10.10.10.4/255.255.255.0
read = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
write = system,call,log,verbose,command,agent,user,config,command,dtmf,reporting,cdr,dialplan,originate
"manager.conf" 27L, 930C

With the above settings i also get the error on my GUI in freepbx under asterisk

i searched some relevant answers on freepbx forum and tried to uninstall the iSymphony on freepbx still the samething

my queXS is not running on the same machine with freepbx

Is there any possibility i can get this right because its sound like i am at the end of everything.

thank you again for your early response ,your help means a lot to me

Best Adam Zammit (adamzammit) said : #3

I think the error of " manager.c:2666 authenticate: 127.0.0.1 failed to authenticate as 'admin'" is related to the changing of the permit line. Please add another permit line that reads:

permit = 127.0.0.1/255.255.255.0

This should fix the freepbx error.

The "Cannot be completed as dialed" error could be something to do with the outbound route / trunk settings in freepbx. Make sure when testing that you are dialing the number exactly as queXS is - it is possible that if the number starts with a 0 it is being truncated.

Regards,
Adam Zammit

Nkosy (gabuza24) said : #4

Thanks Adam Zammit, that solved my question.

Nkosy (gabuza24) said : #5

Hi Adam

thank you so much , your answers solved my problems

Thank you again for this project its really helping