Sample Import Error

Asked by Aung Thura on 2015-08-24

Hi

I appreciate very much your work and effort you put into this project. I am currently trying to run Quexs and faced some difficulties. Most have been solved in the meantime. However, when importing samples from the test csv file, I see the First Name, Last Name and Phone Numbers. After setting the phone number to the type Primary Phone Number and after clicking on Add Sample, the error message "0Error importing file. Please try again" appears. Could please someone give me an idea what went wrong? I am currently using quexs-1.12.1. Thanks for your support.

Aung

Question information

Language:
English Edit question
Status:
Answered
For:
queXS Edit question
Assignee:
No assignee Edit question
Last query:
2015-08-27
Last reply:
2015-08-28
Adam Zammit (adamzammit) said : #1

Dear Aung,

Are you using the Windows easy install version (XAMPP) or have you installed it yourself? If you have installed it yourself, can you please specify the operating system and the versions of mysql, php used?

Also please check you have set a valid default time zone as this can also cause import issues.

Regards,
Adam Zammit

Aung Thura (aung-thura) said : #2

Dear Adam,

Thanks for the quick reply. I installed it on Ubuntu 15.04. mysql is 5.6.25 and php 5.6.4-4ubuntu6.2.

The default time zone is set to Asia/Rangoon. However, when I go to the set default shift times, I see on top written: "Your database does not have time zones installed. Please see here for details".

Could it be related to that? And what would I need to do in that case? Thanks for your help.

Best regards
Aung Thura

Adam Zammit (adamzammit) said : #3

Sounds like the issue.

See here: https://dev.mysql.com/doc/refman/5.1/en/time-zone-support.html

Basically you need to run this command from the terminal:

mysql_tzinfo_to_sql /usr/share/zoneinfo | mysql -u root mysql

Aung Thura (aung-thura) said : #4

I tried that one. But it shows:

Warning: Unable to load '/usr/share/zoneinfo/iso3166.tab' as time zone. Skipping it.
Warning: Unable to load '/usr/share/zoneinfo/zone.tab' as time zone. Skipping it.

After this, the timezone warning on top is still there although I can select time zones. Importing does still not work. My timezone is Rangoon. I guess I have to choose Asia/Rangoon. Any other idea?

Adam Zammit (adamzammit) said : #5

Does the database user for queXS set in config.inc.local.php have write access to the database? Have you loaded the queXS database structure from database/quexs.sql?

This documentation may assist:

http://quexs.sourceforge.net/node/35

Can you help with this problem?

Provide an answer of your own, or ask Aung Thura for more information if necessary.

To post a message you must log in.