Database not in a folder but at a (fixed) sub-domain. How to link?

Asked by Christian Jeske on 2020-08-14

Hello,

I installed queXF on a managed server we rent for our homepage and for limesurvey. The databases on this server they are not in a folder, but they are located at a sub-domain. mysql5.our-homepage.tld.

Now for limesurvey it works if I just use:

'connectionString' => 'mysql:host=mysql5.our-homepage.tld;port=3306;dbname=xxxxxx;',

And provide it with Username/Password. Connects to the DB and writes and so on.

Now I tried multiple versions, with port, without, just the name, with =host and so on. but I always get the same error:

failed to open stream: No such file or directory / ERROR: Please modify config.inc.php to point to your ADODb installation

Is it possible to link it somehow to this MSQL DB?

Thanks in advance!

Chris

Question information

Language:
English Edit question
Status:
Solved
For:
queXF Edit question
Assignee:
No assignee Edit question
Solved by:
Christian Jeske
Solved:
2020-09-09
Last query:
2020-09-09
Last reply:
2020-09-08

This question was reopened

Adam Zammit (adamzammit) said : #1

Hi Chris,

queXF should work on that installation.

The error you are receivieng is not due to the database hostname, but the location of ADODB.

Please make sure you have also downloaded ADODB: https://sourceforge.net/projects/adodb/files/latest/download

And that you reference the location correctly in the queXF config.inc.php file.

Adam

Christian Jeske (cjeske) said : #2

Ah.. yes, I linked the location of the DB instead of the location of ADODB Folder. Now the database error is gone! Thanks!

Christian Jeske (cjeske) said : #3

Thanks Adam Zammit, that solved my question.

Christian Jeske (cjeske) said : #4

Ah, only partly true, the ADODB error is gone, but I still can't connect to the DB.

Could not connect to database. Make sure the database: db306065_6 exists on mysql and that db306065_6 has privileges to it, otherwise modify config.inc.php to point to the correct database. Also make sure you have loaded the database structure from quexf.sql

I imported the structure and confirmed it with sqladmin. So the DB exists and has to structure.

I still don't know how to tell the config-inc to link to a URL with a specific port though. And I think that is my problem?

mysql:host=mysql5.our-homepage.tld;port=3306; (the Connection string from lime Survey that works and accesses the LS db

Christian Jeske (cjeske) said : #5

The username of the DB is == Name of the DB. Both is fixed by the Hosting Provider. The Password that is in the config is the same as on the configuration page of the mysql, checked that too. So those 3 Things should work.

Instead of mysql5.ihre-domain.tld I could also use the IP: 127.0.0.3. But again, I have no clue where to put it.

I'm so close to have this working just too stupid to find where to Input that Information for quexf to find my DB.

Adam Zammit (adamzammit) said : #6

In config.inc.php here are the database settings. The default port for mysql is 3306 so you shouldn't need to change that.

So from what I can gather here is what you should set, where YOURPASSWORD is the password:

define('DB_USER','db306065_6');
define('DB_PASS','YOURPASSWORD');
define('DB_HOST','mysql5.ihre-domain.tld');
define('DB_NAME','db306065_6');

Christian Jeske (cjeske) said : #7

Database connection succeeded!

Thank you so much. It really was that one Change. I had "DB_Host" as mysql and not the link.