Installation issue or software incompatability?

Asked by Phil White on 2017-10-19

Hi. I am attempting to set up a new installation.
Setting up on a Debian 9.2 system, apache2.4.25, mariabd 10.1.26, php 7.0.19-1.
firefox ESR 52.3.0
BasicAuth access secured by .htpasswd.
Accessing qx=uexf via both http://localhost/quexf and http://my-host.local.net/quexf
So far, I've tried queXF 1.19.0 & 1.20.2 -- both with exactly the same outcome.

I can log in. I can see, and verify, "System Setup / Text Configuration" -- Passed Configuration Test.
However, I can't appear to be able to do much else.
"Test Form Compatability" gives me an upload form. Attempting to upload Test_Original.pdf gives nothing more than a white page (still with the menu on the LHS).
Attempting to upload a new form (again using Test_Original.*) gives "Failed to import as no pages were detected", & "Failed to import as no pages were detected". This is on a clean database install.
Other menu items giving a blank RHS include:
Touch-up a form; Band a Form; interactive banding; limesurvey integration (Limesurvey works great, BTW); ... and a lot more...

The most annoying thing is that it almost seems to work, but I have no idea what is wrong. There are no helpful error messages that I can see (I've even tried the 'debug' option in the config file.

Can I have some suggestions please?

Thanks,
Phil

Question information

Language:
English Edit question
Status:
Solved
For:
queXF Edit question
Assignee:
No assignee Edit question
Solved by:
Phil White
Solved:
2017-10-31
Last query:
2017-10-31
Last reply:
2017-10-23
Adam Zammit (adamzammit) said : #1

Hi Phil,

Can you please check the apache log files and see if any detail is given there (usually in /var/log/apache2 on debian dists)?

Adam

Phil White (whitepj) said : #2

Hi Adam
Thanks for getting back.

OK. I am narrowing down what is going on. My first thought was something like a mime error. The lack of any sort of message on the div id=main, object=mainobj was frustrating, and led to incorrect conclusions about incompatibilities, mime file config errors and http headers being wrong.

I do appear to have a problem with ghostscript. I had problems with this years ago on another issue as well -- due to the different forked versions. Currently have GPL Ghostscript 9.20 -- and receiving an "Unrecoverable Error" message when attempting to load the test_original form. I am investigating, but suggestions welcomed.

What is really weird is that I get the "Unrecoverable Error" ONLY (so for) when submitting either 1.19.0/doc/test_original.pdf or 1.20.2/doc/test_original.pdf. Test_blank.pdf appears to work OK. It was the failure of the default test pdf that triggered my first email.

test_blank.pdf successfully imports, as does a self-produced PDF form. I also appear to be able to manually band the form (even if I don't know what I am doing yet!)

However, I am also getting reams of PHP Notices. Apache error.log available if helpful.

Adam Zammit (adamzammit) said : #3

Hi Phil,

I have tested ghostscript with test_original.pdf using GS 9.20 on stock debian 9.2 without difficulty.

Maybe try re-installing the original or reinstalling it if you still have problems.

The notices should be fine to ignore - there is a bit of cleaning up in the code that needs to be done to clear those up but they shouldn't affect use.

Adam

Phil White (whitepj) said : #4

Hi Adam,
Sorry for the delay. I get limited time to test and check.
This looks like a GS problem rather then a queXF one to me -- so I'm going to mark it closed. Thanks for all your help -- as it appears I can test with a self-generated form, I am going to crack on with this.
Many thanks again
Phil

Phil White (whitepj) said : #5

--