Cannot zoom in and out

Asked by toomuch on 2019-02-03

Hello!

I cannot zoom in and out. Not via Ctrl + Mousewheel up / down nor via Ctrl + - & Ctrl + +. Even the buttons in the View menu have no effect at all. Can you please give me a hint, what could be wrong?

I use version 0.4.16 on OpenSUSE Tumbleweed.

Question information

Language:
English Edit question
Status:
Solved
For:
qpdfview Edit question
Assignee:
No assignee Edit question
Solved by:
toomuch
Solved:
2019-03-10
Last query:
2019-03-10
Last reply:
2019-03-09
Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

toomuch (toomuch) said : #5

Can someone please look into this and give me a hint?

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

toomuch (toomuch) said : #7

Can someone please look into this and give me a hint? It's really annoying.

Adam Reichold (adamreichold) said : #8

Hello toomuch,

what is you describe is definitely quite problematic. However, there is also little information that would help to diagnose and hence fix the issue.

Some generic things you could do:
* Run qpdfview from a terminal and see if any additional messages are logged.
* Install the dailydebs from [1] to see if the issue has already been fixed there.
* Try to rename the config file at ~/.config/qpdfview/qpdfview.conf to see if resetting the configuration helps.

The only thing that comes too mind which could explain what you are seeing is that qpdfview has a "hidden" setting called "zoomFactor" which defaults to 1.1, e.g. zooming in/out by 10%. If this got changed to 1.0 somehow, this would explain what you are experiencing. So you could try editing ~/.config/qpdfview/qpdfview.conf and remove any lines containing "zoomFactor=" which should reset the value to its default.

Best regards,
Adam

toomuch (toomuch) said : #9

Hello Adam,

thanks for the suggestions and sorry for the bad environment description.

It was indeed: ~/.config/qpdfview/qpdfview.conf: zoomFactor = 1.0 -> 1.1. Thank you very much!

I have no idea, how that setting would be set to 1.0.