Qt4/Qt5 keyboard shortcuts and N-up printing

Asked by Da Long on 2017-07-08

I recently opened a bug because I could not use the "proper" keyboard shortcuts with a BEPO (french Dvorak) session and keyboard : https://bugs.launchpad.net/qpdfview/+bug/1702045

Adam Reichold suggested (rightfully) this could be a Qt5 integration problem. Indeed, qpdfview was compiled without Qt5 support. So I upgraded my compile environment (Gentoo), threw in a few libraries updates and compiled again qpdfview.

This solved the shortcuts problem *but* I lost the ability to N-up printing, which diseappeared from the Extended options (I only have "Fit to page" and "Page ranges").

If I compile qpdfiew without Qt5 support, without any other library change, I loose the shortcuts and get back the N-up printing.

Does this ring a bell for you ?

I'm a little reluctant to open a new bug since the previous one turned out to be a local configuration problem. Any idea how I could investigate this weird behaviour and get both keyboard shortcuts and N-up printing ?

Question information

Language:
English Edit question
Status:
Solved
For:
qpdfview Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Reichold
Solved:
2017-07-08
Last query:
2017-07-08
Last reply:
2017-07-08
Best Adam Reichold (adamreichold) said : #1

Hello Da Long,

with recent versions of Qt 5, the N-up printing is now part of the frameworks printing properties and hence it has been removed from qpdfview's extensions of the printing dialog. You should find the relevant options in the printer properties in the section "Page layout".

Best regards, Adam.

Da Long (dalong) said : #2

I should have searched a little more... My bad.
Thanks !

Da Long (dalong) said : #3

Thanks Adam Reichold, that solved my question.