Latest version on wheezy

Asked by IhLeon

Hi to all,

I'm working on a debian wheezy, and I would like to know if a .deb of the latest version (or newer than 0.3.1-1) of qpdfview is available.

I'm not the administrator of my computer, and I'm not very familiar with linux. So, just in case u've any advice, before to call the computer service...

Thank you.

Question information

English Edit question
qpdfview Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Adam Reichold (adamreichold) said :


Benjamin is definitely the most qualified to answer this and will hopefully read it on the mailing list. But just to clear one thing: If you do not have administrator privileges, can you actually install Debian packages? Or can you adjust the package management configuration? If not, building the program from source and installing it into your home directory might be the only way to get a more recent version.

Best regards, Adam.

Revision history for this message
Benjamin Eltzner (b-eltzner) said :


first of all, I would like to underline what Adam said. If you do not have superuser rights, you cannot install software systemwide and then unfortunately your only option would be to compile qpdfview manually. (Compiling is quite simple, if the necessary packages qpdfview depends on are installed. You can read instructions in the README file.)

If your admin is open to suggestions, one possibility is to install the version from testing or unstable via apt-pinning. As they are built against package versions that are available in Wheezy, this should not cause problems at the moment. This cannot, however, be taken for granted. The "textbook" solution here would probably be for me to bring the current version into the Wheezy backports. I have not bothered doing so yet because of the modest user base of qpdfview.

So, is it possible for you to make suggestions to your admin? Does your admin already use backports by default?

Revision history for this message
IhLeon (virgile-haw) said :


thank both of you for your replies. I tried to compile, but unfortunately, some of the necessary packages aren't installed.

I'll will talk to all your suggestion with my admin.

Thank you for your work, because even the outdated 0.3.1 version is the best pdf reader for me.