What dock does Qimo use?

Asked by stlubuntu on 2009-08-31

As I coordinated the receipt of a donation of 30+ iMac G3s to my church, I built a Qimo Lite Power PC remix on a Debian Lenny base using the LXDE desktop (for the church pre-school to use) by basically just adding the same games and packages you used for Qimo. (Frankly, I have found Xfce not to be light enough for truly old and slow machines like these.)

My question is what dock did you use and will it install to LXDE (which is GTK+ based.)?

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Qimo Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Hall
Solved:
2009-09-01
Last query:
2009-09-01
Last reply:
2009-08-31
Best Michael Hall (mhall119) said : #1

Qimo uses just the XFCE Panel for the game launchers. I would imagine you could do the same with LXDE's panels, if you can have them not expand to the full screen width and stay centered at the bottom.

Do you have an installable image that you used for those machines? I have a couple of G3 iMacs that I'd love to use that on, and also look into replacing XFCE with LXDE for Qimo.

stlubuntu (jlrbennett) said : #2

Thanks for the response, friend. Your comment and request for an image got me thinking and looking into remastersys. I attempted to install it and ended up in dependency hell. Both syslinux and memtest86+ were both dependencies and not installable (even after enabling both squeeze and sid one at a time separately.)

Anyway, I started by boot to and installing a base command line system from
http://cdimage.debian.org/debian-cd/5.0.2a/powerpc/iso-cd/debian-502a-powerpc-xfce+lxde-CD-1.iso
(do not select install desktop environment or xfce will be installed), boot into your new command line system and then perform
# apt-get install lxde lxnm sudo
# shutdown -r now
reboot into your new lxde system and begin configuring as desired. I applied the Qimo desktop background, did two desktop panels (to look and act like gnome.) Then, I enabled the debian-multimedia repository, the us contrib non-free repos to add synaptic and update-manager. Also, I configured sudoers to match ubuntu (and added the admin group to /etc/group via groupadd admin. Also installed gconf-editor and set /apps/gksu/sudo-mode to true (checked it.) Then I apt-get installed the qimo games and apps, also vlc, gnash (mozlilla-gnash-plugin), and openJDK. Further, via a workaround with repos, I installed Iceweasel 3.5.

Caution, I strongly recommend using apt-get and NOT aptitude as aptitude got confused and deleted my entire lxde desktop files (not just the meta-package file but the underlying files, too.)

Hope this helps. Sorry, but I have not yet figured out how to get remastersys installed on this powerpc (however I did install and use aptoncd and made a cd containing the updates.)

stlubuntu (jlrbennett) said : #3

Thanks mhall119, that solved my question.