Installing qimo on an existing desktop

Asked by boky on 2010-08-09

I would like to share my existing desktop computer with my kids.

That will mean creating a separate login for each of the kids, but the main topic is:
- use existing ubuntu instalation
- have "grown-up profiles" running Gnome
- have "kid profiles running qimo

How do I go around making this possible? I would thing that adding a PPA and installing packages and messing around with start-up scripts would do the trick, but I did not find a suitable tutorial available.

Thanks,
B

Question information

Language:
English Edit question
Status:
Solved
For:
Qimo Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Hall
Solved:
2010-09-21
Last query:
2010-09-21
Last reply:
2010-08-09
Best Michael Hall (mhall119) said : #1

There is a qimo-session package in the Lucid repositories that will install Qimo and all it's dependencies (Xfce and some Xubuntu configs). Then, from GDM, you can select which session you want to use: Gnome or Qimo (You'll also have Xfce and Xubuntu options, by virtue of dependencies).

Note, this has the unintended side-effect of installing the Xubuntu boot screen and GDM theme, these can be changed back to the original Ubuntu ones if desired.

boky (verynotbad) said : #2

The following got installed:

The following NEW packages will be installed:
  aumix{a} aumix-common{a} childsplay{a} childsplay-alphabet-sounds-bg{a} exo-utils{a} gnucap{a} laby{a} libexo-0.3-0{a} libexo-common{a}
  libfltk1.1{a} libthunar-vfs-1-2{a} libxfce4menu-0.1-0{a} libxfce4util-bin{a} libxfce4util-common{a} libxfce4util4{a} libxfcegui4-4{a}
  libxfconf-0-2{a} mousepad murrine-themes{a} orage oss-compat{a} python-sqlalchemy{a} qimo-games qimo-session qimo-wallpaper thunar{a}
  thunar-data{a} thunar-volman{a} ttf-bengali-fonts{a} ttf-devanagari-fonts{a} ttf-gujarati-fonts{a} ttf-kannada-fonts{a} ttf-oriya-fonts{a}
  ttf-sil-andika{a} ttf-sil-doulos{a} ttf-tamil-fonts{a} ttf-telugu-fonts{a} tuxmath{a} tuxpaint{a} tuxpaint-config{a} tuxpaint-data{a}
  tuxpaint-plugins-default{a} tuxpaint-stamps-default{a} tuxtype{a} tuxtype-data{a} xfce-keyboard-shortcuts{a} xfce4-panel xfce4-session
  xfce4-settings{a} xfce4-utils{a} xfconf{a} xfdesktop4{a} xfdesktop4-data{a} xfwm4{a} xfwm4-themes{a} xubuntu-artwork{a}
  xubuntu-default-settings xubuntu-gdm-theme{a} xubuntu-icon-theme{a} xubuntu-plymouth-theme{a} xubuntu-wallpapers{a}

I had to do some tweaking afterwards (sudo -u gdm ...) but onther than that, turned out perfectly.

boky (verynotbad) said : #3

Thanks Michael Hall, that solved my question.