Merge not working as I expected

Asked by George Karakostas on 2010-10-06

Hello,

I am new to Bazaar and to VCS in general. I use v2.1.1 with qbzr on Ubuntu. I have set up a repository on my file server and a branch on my desktop with sftp. After I make changes locally, I commit them, so the branch gets a new revision number. When I try to merge the branch back to the parent location, it returns me 'nothing to do'. But the files on parent remain different than the local branch. Is this normal? Maybe I should push the branch back to the parent, but this not how I understand things.

Many thanks.

Regards

Question information

Language:
English Edit question
Status:
Solved
For:
QBzr Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Pool
Solved:
Last query:
Last reply:
Revision history for this message
Best Martin Pool (mbp) said :
#1

I'm not sure I understand enough about your setup to answer well. One key think is that you always merge into a working tree. When you're done on your feature branch, you need to either push that to the server, or merge it into a local branch bound to the server.

Revision history for this message
George Karakostas (gckarakostas) said :
#2

Thanks Martin Pool, that solved my question.