Error with 'America/Santiago' and tz database maintainer list defunct?

Asked by Jonathan Berger on 2013-03-12

I believe I've discovered an error with the definition of 'America/Santiago' and I tried contacting the tz database mailing list at the address "<email address hidden>". My mail bounced.

Through some Googling, it seems the current address might be "<email address hidden>". This address did not bounce but I have not heard back yet.

The problem with 'America/Santiago' is that as of 2013-03-12 at 22:30 it reports the offset to be CLT-0400 when I believe it actually should be CLST-0300 (according to Wikipedia, WorldTime.com and TimeAndDate.com).

Has anyone else encountered either of these problems?
* The tz database webpage being out of date.
* 'America/Santiago' being incorrect.

Thanks,
Jonathan
Maintainer of thetimezoneconverter.com

Question information

Language:
English Edit question
Status:
Solved
For:
pytz Edit question
Assignee:
No assignee Edit question
Solved by:
Stuart Bishop
Solved:
2013-03-14
Last query:
2013-03-14
Last reply:
2013-03-14

Upon further research from Wikipedia ( http://en.wikipedia.org/wiki/Tz_database#Move_to_ICANN ), it appears the new authoritative page for the tz database is:
http://www.iana.org/time-zones

(instead of the previous http://www.twinsun.com/tz/tz-link.htm )

Perhaps the pytz documentation should be updated to this new link?

People on the <email address hidden> list have reported this has been fixed with the 2013a release of the tz database.

I'm not sure how to update manually the tz database that pytz uses.

Maintainers of pytz: could we release a new version of the library?

Best Stuart Bishop (stub) said : #3

pytz-2013b has been released.

Stuart Bishop (stub) said : #4

The link has been updated on my branch, and will be included in the next release.

Thanks Stuart Bishop, that solved my question.