yet another remapping problem

Asked by Urviech

Hi Raumkraut,

i tried pystromo 0.6 for my n52te, roughly following the guide from the ubuntu forums. (

as i got the known permission error i set the correct permissions manually / ran pystromo-remap as root (tried both). that workaround did the trick as far as the permissions problem goes, but remapping still doesn't work.

when i start "./pystromo -m <map>" (i tried the and my i get:

/home/urviech/.config/pystromo/lib/ DeprecationWarning: object.__init__() takes no parameters
  tuple.__init__(self, *args, **kwargs)
/home/urviech/.config/pystromo/lib/ DeprecationWarning: object.__init__() takes no parameters
  tuple.__init__(self, *args, **kwargs)
/home/urviech/.config/pystromo/lib/ DeprecationWarning: object.__init__() takes no parameters
  tuple.__init__(self, *args, **kwargs

what i have learned is normal and not an error, but after that nothing happens. neither does the remapper terminate, nor are the keys remapped.

same goes for ./pystromo-remap -v:

Using output: <lib.devices.OutputDevice object at 0xcc29d0>
Loading mappings

and then nothing. ctrl+c ends the task.

here's my lsusb output:

Bus 002 Device 005: ID 0d8c:0201 C-Media Electronics, Inc. CM6501
Bus 002 Device 004: ID 050d:0200 Belkin Components
Bus 002 Device 003: ID 1532:000d Razer USA, Ltd
Bus 002 Device 002: ID 046d:c512 Logitech, Inc. LX-700 Cordless Desktop Receiver
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0ace:1215 ZyDAS WLA-54L WiFi
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the distribution i use is arch linux x86_64.

i looked around here for that issue, but didn't find too much. so - any ideas so far? would be nice to get the nostromo to work with my arch!



Question information

English Edit question
Pystromo Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Urviech (x-zum-quadrat) said :

little update: it doesn't seem to be evdev - i just disabled it (what is it good for anyway?) and restarted x - still the same issue.

Revision history for this message
Urviech (x-zum-quadrat) said :

ok, while i was again trying to get it to work just now, i found this bug description:

well, i tried ./pystromo-remap -m -v to see if my was the fault - it wasn't, but for some reason it worked now - my keys are remapped.

i tried again without the -v and it worked as well (as it should) - i don't know why the remapping works now, but im happy it does. so this one is kind of "solved".

thanks a lot for your work.

Revision history for this message
Raumkraut (raumkraut) said :

I'm glad to hear you managed to get it working in the end.

For posterity: The only thing which jumps out at me about the problem you were having was that, after the "Loading mappings" line of the -v output, there should have been a line like "Using device...". That there wasn't, indicates that it wasn't able to find the relevant node/s in /dev/input. I would guess that it was most likely a permissions issue, which was consequently corrected after a reboot/re-plug.