Sometimes works, sometimes doesn't, how do I troubleshoot?

Asked by Byron Gibson

Sometimes I run pystromo and it works perfectly, other times I start it up and it doesn't work at all (as if it's not even running). It seems arbitrary, I'm not sure what is different when it works, or where to begin troubleshooting. Just looking for suggestions on how to troubleshoot it.

Run command: sudo sh -m

I put in the same folder as since I use the same key mapping for everything, don't need different profiles. Still have to run it via sudo, won't run otherwise.

Any suggestions much appreciated.

Question information

English Edit question
Pystromo Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Byron Gibson (byrongibson) said :

More info:

After trying several times:

sudo sh -m

I changed to:

sudo ./ -m

and it worked first time.

However, I know sh has also worked sometimes in the past. Any clue what's going on here?

Revision history for this message
Best Raumkraut (raumkraut) said :

Attempting to run with `sh` (which is what your original command was doing) should never have worked, as `sh` would have no idea how to interpret the Python code. It would have most likely output a few lines of "...: not found" and a final "Syntax error" to the console, before quitting.
Perhaps, on those occasions that it did appear to work, it was actually another Pystromo process running elsewhere which was operating? Unless sometimes you just forgot to put the (erroneous) "sh" in the command! :D

Revision history for this message
Byron Gibson (byrongibson) said :

Thanks Raumkraut, that solved my question.